summaryrefslogtreecommitdiff
path: root/dev-ml/dune/dune-2.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-ml/dune/dune-2.7.1.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-ml/dune/dune-2.7.1.ebuild')
-rw-r--r--dev-ml/dune/dune-2.7.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/dune/dune-2.7.1.ebuild b/dev-ml/dune/dune-2.7.1.ebuild
new file mode 100644
index 000000000000..c66681198140
--- /dev/null
+++ b/dev-ml/dune/dune-2.7.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multiprocessing
+
+DESCRIPTION="A composable build system for OCaml"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND="dev-lang/ocaml"
+RDEPEND="${DEPEND}
+ !dev-ml/jbuilder"
+BDEPEND=""
+
+RESTRICT="test"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ ocaml bootstrap.ml || die
+ ./dune.exe build -p "${PN}" --profile dune-bootstrap -j $(makeopts_jobs) || die
+}
+
+src_install() {
+ default
+ mv "${D}"/usr/doc "${D}"/usr/share/doc/${PF}
+ mv "${D}"/usr/man "${D}"/usr/share/man
+}