summaryrefslogtreecommitdiff
path: root/dev-ml/dune-build-info/dune-build-info-3.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-16 11:50:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-16 11:50:23 +0100
commita2844b413d00a2859401e017a0311986151e1594 (patch)
tree3758da107fb05d4012a3f4813be2bf13c03d3985 /dev-ml/dune-build-info/dune-build-info-3.7.1.ebuild
parent1ac83daac7198a5717483e1cfab669ba4f12debe (diff)
gentoo auto-resync : 16:04:2023 - 11:50:23
Diffstat (limited to 'dev-ml/dune-build-info/dune-build-info-3.7.1.ebuild')
-rw-r--r--dev-ml/dune-build-info/dune-build-info-3.7.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/dune-build-info/dune-build-info-3.7.1.ebuild b/dev-ml/dune-build-info/dune-build-info-3.7.1.ebuild
new file mode 100644
index 000000000000..2b60d3970e73
--- /dev/null
+++ b/dev-ml/dune-build-info/dune-build-info-3.7.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune multiprocessing
+
+DESCRIPTION="Embed locations informations inside executable and libraries"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz -> dune-${PV}.tar.gz"
+S="${WORKDIR}/dune-${PV}"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+RDEPEND=">=dev-ml/dune-3.5"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ dune build -p ${PN} @install --display short -j $(makeopts_jobs) || die
+}