summaryrefslogtreecommitdiff
path: root/dev-ml/dns-async
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/dns-async
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/dns-async')
-rw-r--r--dev-ml/dns-async/Manifest3
-rw-r--r--dev-ml/dns-async/dns-async-1.0.0.ebuild42
-rw-r--r--dev-ml/dns-async/metadata.xml11
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-ml/dns-async/Manifest b/dev-ml/dns-async/Manifest
new file mode 100644
index 000000000000..d497aba52e4a
--- /dev/null
+++ b/dev-ml/dns-async/Manifest
@@ -0,0 +1,3 @@
+DIST ocaml-dns-1.0.0.tar.gz 99161 SHA256 823410badaf2faf54ca8a59472b0ad82c4db9fe4ef92f6809061baa826851226 SHA512 199653605e985851dcaafc94f1efeba5c261c29cd5e5f8eaebc9f7d25a05c43adcf7620efb291b22f9549f7c05f8ac3f6abfbcf40e0d7762bd2f7cd623ebcb1c WHIRLPOOL e7c26857270d92be2e8e068ac29119ef5d82d52fd739b8304e84c595d6a6e7fc11c22ed98e4a6d99a20f4e9d1d6b28dbc76c333d6b464bbd1dc4d37597cfe66c
+EBUILD dns-async-1.0.0.ebuild 754 SHA256 a1c333dc1e0249273f8321e4a56e210bd3d4bad26e66343acf7af5ad9ff61f08 SHA512 52dc613bb6219b8a0e7f61563f20a1429230e441a204734828ef94fde4f28cbe724b6947a8d40af88f8b2e020e0e6d9980e37a9b0f4770235f7bb10b447908aa WHIRLPOOL f6e5661e8f422f81d0db717906f74c8ef114a999589c119e5afe33856a911fc5a99bbb50ffcfe42b04d54dceed9d4116fdf33bd82a8ff9a2ee17c7d3005e020f
+MISC metadata.xml 357 SHA256 ab112ea05e172fd6ae8ed46e6d2cc5e7d235fc6cf38d55c0a69b02243c7bcc76 SHA512 9e3065fb6377e861b64a34f9fafd75e33a0edb081d273a8918b494a1d6f79c63ffb2c9b33bd854bb893fa020652c15b575d3e16e08266895239c082f28429633 WHIRLPOOL a2d9399b37c27bab7a3b137a828ba9e0038228c1f9f3a4fb0e04c6d3e737acc591a98bad801b9fe2d6449caf70fe5952397badda1c98c25731f3f81fa8420c58
diff --git a/dev-ml/dns-async/dns-async-1.0.0.ebuild b/dev-ml/dns-async/dns-async-1.0.0.ebuild
new file mode 100644
index 000000000000..f7df7c7eccf3
--- /dev/null
+++ b/dev-ml/dns-async/dns-async-1.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib opam
+
+MY_P=ocaml-dns-${PV}
+
+DESCRIPTION="Async support of OCaml DNS"
+HOMEPAGE="https://github.com/mirage/ocaml-dns https://mirage.io"
+SRC_URI="https://github.com/mirage/ocaml-dns/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="LGPL-2 LGPL-2.1-with-linking-exception ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4:=
+ dev-ml/async:=
+ dev-ml/dns:=
+"
+DEPEND="
+ dev-ml/jbuilder
+ test? (
+ dev-ml/dns-lwt-unix
+ )
+ ${RDEPEND}
+"
+# Do not work
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ jbuilder build @install -p ${PN} || die
+}
+
+src_test() {
+ jbuilder runtest -p ${PN} || die
+}
diff --git a/dev-ml/dns-async/metadata.xml b/dev-ml/dns-async/metadata.xml
new file mode 100644
index 000000000000..2f4ef14adaa5
--- /dev/null
+++ b/dev-ml/dns-async/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mirage/ocaml-dns</remote-id>
+ </upstream>
+</pkgmetadata>