summaryrefslogtreecommitdiff
path: root/dev-ml/csv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/csv
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/csv')
-rw-r--r--dev-ml/csv/Manifest7
-rw-r--r--dev-ml/csv/csv-1.5.ebuild23
-rw-r--r--dev-ml/csv/csv-1.6.ebuild28
-rw-r--r--dev-ml/csv/csv-1.7.ebuild37
-rw-r--r--dev-ml/csv/metadata.xml14
5 files changed, 109 insertions, 0 deletions
diff --git a/dev-ml/csv/Manifest b/dev-ml/csv/Manifest
new file mode 100644
index 000000000000..0ae6dcad6d17
--- /dev/null
+++ b/dev-ml/csv/Manifest
@@ -0,0 +1,7 @@
+DIST csv-1.5.tar.gz 83642 BLAKE2B e07303a4be8c4e75964b4ecc38da59de288e12b433ecb4a5d5450b21411b2343b38853cdf2737516185867d2f3963cc374c9ec34df96332b5844bbd850fb7c89 SHA512 1c8af0ce8abd8a5710115c194eee34928399964447309ee974665cf427396def42bca4f983904bfec706f7944aea419a87bf54bc6c379cb8b7372be801be4126
+DIST csv-1.6.tar.gz 98194 BLAKE2B 1c7975ec92bcd63cdeee369e8a3507b6ef95cf646cba2f5498983a18098f8147a26d7ae57a37904a3f1cc21085e7f2f2ffc9ec7bca836d6edc31a45d2de4c0a3 SHA512 689dae2dd57ec914ca1dd5e3d34ebd352aabb7d5da8933aa6c6fc9c6ec84dc538d1df8a1c46f3e172ab09e5917e9158be76afb2423ec8a92eef489ac5dfd5175
+DIST csv-1.7.tar.gz 45160 BLAKE2B 2f51f927d9099382a227e20471e60075f8796d7753152e266c121f705e4dab7036659937630302f152cd8f28d6db1aee3d5c72c339a45477292ee03c4bc461ab SHA512 cbe3d316e6f99318b3958bbfba3308225e709afb481a333d314adb66c20683171c23ac0565fc8d8e936b9dad13b9330b5208340b9fc671b4ccddf3a7d8b82b3e
+EBUILD csv-1.5.ebuild 517 BLAKE2B d03abc8fea95c38094dca18547eb57c188378a45250529cd0073e9dba05e39ce04617e8bb3e264b6cfce7d2d76386173ba83e61ad3754231e056337e3b1227a7 SHA512 cfcd84f23bd246fc5e225dbf02d81b1ef091f1af8e193689ec07bf69fed40585a81a4f4b97a72f91ee2246c37ea823a5be4ddeb002ef4564a5e6b51631677de9
+EBUILD csv-1.6.ebuild 629 BLAKE2B b0262894ce7b05662b24293efcb2cfb420d8afd820467669cb8d8677680f01a023645ffa680e4283af463cc599c838ba15d206c5044cc6ae658a0d1b50e3e012 SHA512 03093fca7d3c1e1d0391c4365cae27c2f68e4f12b86a625d426ec8112f5e44485adba2b3c332f6afc57c7b92c3c717e83aa4e261b3c659dcc9e3c22e7c8e1580
+EBUILD csv-1.7.ebuild 737 BLAKE2B 5a7e4901f97dff8c2f4c5d25b8ecc6b872bde2c5e57302a726820a7cb7bd8bc86975ee4a541dc6a4ec550e4d7ff89a27e490b59523468797d61f3630abe871bd SHA512 20e561d88b7598be72c68870d38fc16b73d41f8c56563bd906917e4f5683d3880976ac35bd873c8082664c75b0959ad485676b8030aca822c528be3ed75d9598
+MISC metadata.xml 429 BLAKE2B ce09ac06a35a459ef646749b55d32ce3086f7002cb0612dc7350e7884c7850ee739c2bf483b2a2758758ba34e4755e0e1a364a322b1da1d8fd181285c1a65a5d SHA512 1c23697559bc429062f42f54ab55e940eb22777efec99ce865280ba1342ee7f6f6f7a82a7b036a3a5db5d01b68e8e9990bc19e40b4ba7f372123d825b1bd12ff
diff --git a/dev-ml/csv/csv-1.5.ebuild b/dev-ml/csv/csv-1.5.ebuild
new file mode 100644
index 000000000000..29be7c1a8b6c
--- /dev/null
+++ b/dev-ml/csv/csv-1.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="A pure OCaml library to read and write CSV files"
+HOMEPAGE="https://github.com/Chris00/ocaml-csv"
+SRC_URI="https://github.com/Chris00/ocaml-csv/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+DOCS=( "README.txt" "AUTHORS.txt" )
diff --git a/dev-ml/csv/csv-1.6.ebuild b/dev-ml/csv/csv-1.6.ebuild
new file mode 100644
index 000000000000..1d0efd903991
--- /dev/null
+++ b/dev-ml/csv/csv-1.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="A pure OCaml library to read and write CSV files"
+HOMEPAGE="https://github.com/Chris00/ocaml-csv"
+SRC_URI="https://github.com/Chris00/ocaml-csv/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+lwt"
+
+DEPEND="lwt? ( dev-ml/lwt:= )"
+RDEPEND="${DEPEND}"
+
+DOCS=( "README.txt" "AUTHORS.txt" )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable lwt)" \
+ oasis_src_configure
+}
diff --git a/dev-ml/csv/csv-1.7.ebuild b/dev-ml/csv/csv-1.7.ebuild
new file mode 100644
index 000000000000..817e095edb27
--- /dev/null
+++ b/dev-ml/csv/csv-1.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="A pure OCaml library to read and write CSV files"
+HOMEPAGE="https://github.com/Chris00/ocaml-csv"
+SRC_URI="https://github.com/Chris00/ocaml-csv/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+lwt"
+
+DEPEND="lwt? ( dev-ml/lwt:= )"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/oasis"
+
+DOCS=( "README.txt" "AUTHORS.txt" )
+
+S="${WORKDIR}/ocaml-${P}"
+
+src_prepare() {
+ default
+ oasis setup || die
+}
+
+src_configure() {
+ oasis_configure_opts="$(use_enable lwt)" \
+ oasis_src_configure
+}
diff --git a/dev-ml/csv/metadata.xml b/dev-ml/csv/metadata.xml
new file mode 100644
index 000000000000..5008ee553fa7
--- /dev/null
+++ b/dev-ml/csv/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Chris00/ocaml-csv</remote-id>
+ </upstream>
+ <use>
+ <flag name="lwt">Enables the Lwt-based library for asynchronous operations.</flag>
+ </use>
+</pkgmetadata>