summaryrefslogtreecommitdiff
path: root/dev-ml/cstruct/cstruct-6.2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-18 00:10:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-18 00:10:02 +0100
commitccaccfe4f1da8c11d9fa110f6e4eb847358769d7 (patch)
treeff02c95ae3d9a1e73e2a182e268161743d81a88b /dev-ml/cstruct/cstruct-6.2.0-r1.ebuild
parent74e526c590f52d24a213e25f77858ae0b34ec2c8 (diff)
gentoo auto-resync : 18:06:2024 - 00:10:02
Diffstat (limited to 'dev-ml/cstruct/cstruct-6.2.0-r1.ebuild')
-rw-r--r--dev-ml/cstruct/cstruct-6.2.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/cstruct/cstruct-6.2.0-r1.ebuild b/dev-ml/cstruct/cstruct-6.2.0-r1.ebuild
new file mode 100644
index 000000000000..b397c637c091
--- /dev/null
+++ b/dev-ml/cstruct/cstruct-6.2.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Access C-like structures directly from OCaml"
+HOMEPAGE="https://github.com/mirage/ocaml-cstruct"
+SRC_URI="https://github.com/mirage/ocaml-cstruct/releases/download/v${PV}/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? (
+ dev-ml/alcotest
+ dev-ml/cppo
+ dev-ml/ocaml-migrate-parsetree
+ dev-ml/ppx_sexp_conv
+ dev-ml/ppxlib
+ dev-ml/sexplib
+ )
+"
+
+src_compile() {
+ dune-compile ${PN}
+}