summaryrefslogtreecommitdiff
path: root/dev-ml/cryptokit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/cryptokit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/cryptokit')
-rw-r--r--dev-ml/cryptokit/Manifest7
-rw-r--r--dev-ml/cryptokit/cryptokit-1.10.ebuild48
-rw-r--r--dev-ml/cryptokit/cryptokit-1.11.ebuild50
-rw-r--r--dev-ml/cryptokit/cryptokit-1.12.ebuild52
-rw-r--r--dev-ml/cryptokit/metadata.xml11
5 files changed, 168 insertions, 0 deletions
diff --git a/dev-ml/cryptokit/Manifest b/dev-ml/cryptokit/Manifest
new file mode 100644
index 000000000000..deeb1ffd77af
--- /dev/null
+++ b/dev-ml/cryptokit/Manifest
@@ -0,0 +1,7 @@
+DIST cryptokit-1.10.tar.gz 152525 BLAKE2B 51c905757ad141292be89707bdab5c83a1f3e9e2665202cbf17e12b115591c57b77b759b4fa2967d1f00b4cf5bd87445a2189b4d222d5d1613e19c32e1054189 SHA512 22564e0151c492963d75fb81780b3a884a0bf613ad09380d9b5365740fd9c4bbdaa1c21fed50a1a4934dce920d90f5c86dc014f90e52677544789311f7bded4f
+DIST cryptokit-1.11.tar.gz 156905 BLAKE2B 3fc77321c0d525a32f5733d77963b5df4e618b3168f2f00aceeb1e13b16cc202e79b50afa93c0769f016b4e43061ff19851c8ba3f40ad7f8f0c9ff78a51d68e7 SHA512 cc641a05a67cd3d2e5ec481e8d426796db625ab60e89f79bde2e360730892c62f30ea2e37c4b028df16471220847e6d7ce4984deb9528fec6647a17fc4ae1b0d
+DIST cryptokit-1.12.tar.gz 157920 BLAKE2B c26d0642f02cf19502bfce043bfb542bfb7a8e80ac2c7dfbecce48b57d44eddd5f279ceec1166fd2e81e1a8446bb52fa748d89a3f7506860fe1c545784087469 SHA512 f99c50578360c7671029a0c4603b355912899596ea7baf55cb2f94e039658646396f1307417a24b3d87a535d272bed90e79d5e027af034c2c742140c44ec61ff
+EBUILD cryptokit-1.10.ebuild 1266 BLAKE2B cae93a94a2c881fd390be981e142b0661ff4d501910dd040294f6d9630020cd982e23fac5893416af0e608eef34d52324c4f9ecf5eb459acf86b7765313aeb94 SHA512 33a3784e4b33e688c0d5a2fcddf6d2c41fb172e1a3b1118ffdc4e99b4466b4981d8085f8f8c01527a9bbb9d04ced1d3f8b59e25032d358199634e29cf8f5fa5e
+EBUILD cryptokit-1.11.ebuild 1320 BLAKE2B 710bb49174d23d95bc5fe69cd55d8bb99093d7e7b0d6620d3c77a512e2091c80812c72c7c52d9d4c6aeb9ff37baa07c1ebdc96774c92c25ad2a83501e9fa5568 SHA512 83d29976e401df8b24abf397afe426ee34ab4e35ba9de5701821477148e8e5cbbdbc4493eca8cb9efcd1bed52e3096e7f397709151dc6361b99300ffa40f0ff5
+EBUILD cryptokit-1.12.ebuild 1441 BLAKE2B 9ec9d9f5d53747d4d16a226468e3565953cdc41406c681ad51656fb8508a07e82835adedee51475a8d014958396dfcd736987ee65aeffea5efcc9e58840869d1 SHA512 421abe70ebba3b17d44d7777e8ab6a522d06e4b1e64b0dd030d9c7b670eb40ed1bd24402032067b466238ef0b333eb02f79cf5be6317a9137a8601aa7d0957c0
+MISC metadata.xml 333 BLAKE2B 27b0324eacee9742b253832a6c851f2ff70be59371769c25c8a485e3dd183674bb29aac0ef0bc809d8c284fdfe5f39af1e4be010ea4d9f2a1d4db9a5b532ca86 SHA512 da33cc22253a2ff38de20b7ad0888aab7c3a88f26bb853c00ba8e75fc10d325b395ede9dff86035eb81a7c5e08cf9276eacb28ebd8ce2fb0edcfade71471ef71
diff --git a/dev-ml/cryptokit/cryptokit-1.10.ebuild b/dev-ml/cryptokit/cryptokit-1.10.ebuild
new file mode 100644
index 000000000000..e71c0d2103d8
--- /dev/null
+++ b/dev-ml/cryptokit/cryptokit-1.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Cryptographic primitives library for Objective Caml"
+HOMEPAGE="http://forge.ocamlcore.org/projects/cryptokit/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1493/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE="zlib"
+
+DEPEND="zlib? ( >=sys-libs/zlib-1.1 )"
+RDEPEND="${DEPEND}"
+
+DOCS=( "Changes" "README.txt" "AUTHORS.txt" )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable zlib)" \
+ oasis_src_configure
+}
+
+pkg_postinst() {
+ elog ""
+ elog "This library uses the /dev/random device to generate "
+ elog "random data and RSA keys. The device should either be"
+ elog "built into the kernel or provided as a module. An"
+ elog "alternative is to use the Entropy Gathering Daemon"
+ elog "(http://egd.sourceforge.net). Please note that the"
+ elog "remainder of the library will still work even in the"
+ elog "absence of a one of these sources of randomness."
+ elog ""
+}
+
+src_test() {
+ echo ""
+ einfo "You must have either /dev/random or the Entropy Gathering"
+ einfo "Daemon (EGD) for this test to succeed!"
+ echo ""
+
+ oasis_src_test
+}
diff --git a/dev-ml/cryptokit/cryptokit-1.11.ebuild b/dev-ml/cryptokit/cryptokit-1.11.ebuild
new file mode 100644
index 000000000000..bf0d90a57e84
--- /dev/null
+++ b/dev-ml/cryptokit/cryptokit-1.11.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Cryptographic primitives library for Objective Caml"
+HOMEPAGE="http://forge.ocamlcore.org/projects/cryptokit/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1618/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="zlib"
+
+DEPEND="zlib? ( >=sys-libs/zlib-1.1 )
+ dev-ml/zarith:="
+RDEPEND="${DEPEND}"
+
+DOCS=( "Changes" "README.txt" "AUTHORS.txt" )
+REQUIRED_USE="test? ( ocamlopt )"
+
+src_configure() {
+ oasis_configure_opts="$(use_enable zlib)" \
+ oasis_src_configure
+}
+
+pkg_postinst() {
+ elog ""
+ elog "This library uses the /dev/random device to generate "
+ elog "random data and RSA keys. The device should either be"
+ elog "built into the kernel or provided as a module. An"
+ elog "alternative is to use the Entropy Gathering Daemon"
+ elog "(http://egd.sourceforge.net). Please note that the"
+ elog "remainder of the library will still work even in the"
+ elog "absence of a one of these sources of randomness."
+ elog ""
+}
+
+src_test() {
+ echo ""
+ einfo "You must have either /dev/random or the Entropy Gathering"
+ einfo "Daemon (EGD) for this test to succeed!"
+ echo ""
+
+ oasis_src_test
+}
diff --git a/dev-ml/cryptokit/cryptokit-1.12.ebuild b/dev-ml/cryptokit/cryptokit-1.12.ebuild
new file mode 100644
index 000000000000..e728f55a1dde
--- /dev/null
+++ b/dev-ml/cryptokit/cryptokit-1.12.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis versionator
+
+DESCRIPTION="Cryptographic primitives library for Objective Caml"
+HOMEPAGE="https://github.com/xavierleroy/cryptokit"
+SRC_URI="https://github.com/xavierleroy/cryptokit/archive/release$(replace_all_version_separators '').tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86-fbsd"
+IUSE="zlib"
+
+DEPEND="zlib? ( >=sys-libs/zlib-1.1 )
+ dev-ml/zarith:="
+RDEPEND="${DEPEND}"
+
+DOCS=( "Changes" "README.txt" "AUTHORS.txt" )
+REQUIRED_USE="test? ( ocamlopt )"
+
+S="${WORKDIR}/${PN}-release$(replace_all_version_separators '')"
+
+src_configure() {
+ oasis_configure_opts="$(use_enable zlib)" \
+ oasis_src_configure
+}
+
+pkg_postinst() {
+ elog ""
+ elog "This library uses the /dev/random device to generate "
+ elog "random data and RSA keys. The device should either be"
+ elog "built into the kernel or provided as a module. An"
+ elog "alternative is to use the Entropy Gathering Daemon"
+ elog "(http://egd.sourceforge.net). Please note that the"
+ elog "remainder of the library will still work even in the"
+ elog "absence of a one of these sources of randomness."
+ elog ""
+}
+
+src_test() {
+ echo ""
+ einfo "You must have either /dev/random or the Entropy Gathering"
+ einfo "Daemon (EGD) for this test to succeed!"
+ echo ""
+
+ oasis_src_test
+}
diff --git a/dev-ml/cryptokit/metadata.xml b/dev-ml/cryptokit/metadata.xml
new file mode 100644
index 000000000000..fad2f6d52138
--- /dev/null
+++ b/dev-ml/cryptokit/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">xavierleroy/cryptokit</remote-id>
+ </upstream>
+</pkgmetadata>