summaryrefslogtreecommitdiff
path: root/dev-ml/core_unix/core_unix-0.16.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-08 22:23:22 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-08 22:23:22 +0100
commit99b2c44c1425c7b2925846d4c44b2bf2f78dc786 (patch)
tree9bf7a2d385aace0ea5f3f8d3e3657168b758fdaa /dev-ml/core_unix/core_unix-0.16.0.ebuild
parent39bccce90513402ec93bb0fde30678f16b07a9cc (diff)
gentoo auto-resync : 08:07:2023 - 22:23:22
Diffstat (limited to 'dev-ml/core_unix/core_unix-0.16.0.ebuild')
-rw-r--r--dev-ml/core_unix/core_unix-0.16.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/core_unix/core_unix-0.16.0.ebuild b/dev-ml/core_unix/core_unix-0.16.0.ebuild
new file mode 100644
index 000000000000..3abd67fa944c
--- /dev/null
+++ b/dev-ml/core_unix/core_unix-0.16.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit dune toolchain-funcs
+
+DESCRIPTION="Unix-specific portions of Core"
+HOMEPAGE="https://github.com/janestreet/core_unix"
+SRC_URI="https://github.com/janestreet/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/core:=
+ dev-ml/core_kernel:${SLOT}
+ dev-ml/expect_test_helpers_core:${SLOT}
+ dev-ml/ocaml_intrinsics:${SLOT}
+ >=dev-ml/spawn-0.15:=
+ dev-ml/timezone:${SLOT}
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-musl.patch )
+
+src_prepare() {
+ sed -i \
+ -e "s:gcc:$(tc-getCC):" \
+ unix_pseudo_terminal/src/discover.sh \
+ || die
+
+ default
+}