summaryrefslogtreecommitdiff
path: root/dev-ml/core/core-0.9.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-12 16:49:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-12 16:49:02 +0000
commit519e4d5d99fc43d5c9a038098c029dc4ef9d6792 (patch)
tree7e99d88a777fe8c9d3ec6310bf7eea639b0e66b4 /dev-ml/core/core-0.9.2.ebuild
parenta5332b59346f7cbf0fdbd148b54aa8a84aaf8190 (diff)
gentoo resync : 12.11.2017
Diffstat (limited to 'dev-ml/core/core-0.9.2.ebuild')
-rw-r--r--dev-ml/core/core-0.9.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/core/core-0.9.2.ebuild b/dev-ml/core/core-0.9.2.ebuild
new file mode 100644
index 000000000000..d2dbd9555d39
--- /dev/null
+++ b/dev-ml/core/core-0.9.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit opam
+
+DESCRIPTION="Jane Street's alternative to the standard library"
+HOMEPAGE="https://github.com/janestreet/core"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-ml/base:=
+ dev-ml/configurator:=
+ dev-ml/core_kernel:=
+ dev-ml/ppx_assert:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_jane:=
+ dev-ml/sexplib:=
+ dev-ml/spawn:=
+ dev-ml/stdio:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+DEPEND="${RDEPEND} dev-ml/jbuilder"