summaryrefslogtreecommitdiff
path: root/dev-ml/cmdliner
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/cmdliner
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/cmdliner')
-rw-r--r--dev-ml/cmdliner/Manifest7
-rw-r--r--dev-ml/cmdliner/cmdliner-1.0.0.ebuild43
-rw-r--r--dev-ml/cmdliner/cmdliner-1.0.1.ebuild43
-rw-r--r--dev-ml/cmdliner/cmdliner-1.0.2.ebuild43
-rw-r--r--dev-ml/cmdliner/metadata.xml8
5 files changed, 144 insertions, 0 deletions
diff --git a/dev-ml/cmdliner/Manifest b/dev-ml/cmdliner/Manifest
new file mode 100644
index 000000000000..adc4151f9da4
--- /dev/null
+++ b/dev-ml/cmdliner/Manifest
@@ -0,0 +1,7 @@
+DIST cmdliner-1.0.0.tbz 46542 BLAKE2B 7a667e218c298dbe4f5ba8ff034f15596e9b89b1a267fbdf7f6f811e42d61b103b08a2c8b9bd45e83bb249ae5ed078eb646630cd8a174af267354b25dc13ca54 SHA512 3fc87e49504167864ba4d81fde7bbaa01b7d58b06e2b68b36647857590f41fdc8b3bbd547418f8159b0e76628236b5c30301404b3d8d57e2ff3f082228eee73c
+DIST cmdliner-1.0.1.tbz 46614 BLAKE2B 609220b8dbb0aa5ade9f504f420ed7c6ee1ad9aa1f9cd02b1edba60b86791e59a12faca0ebe6ed9cbb5fbeefdfe25b524509bf311f1611022b6c62ae38df01c1 SHA512 b792dab3a7f53f69d74d07acbb013e48235614e29a477b7e9e7d7b58013d47ff842fbaeef50acda305434185325855ef83d839d5acb0ccf460276f0ca880ee7b
+DIST cmdliner-1.0.2.tbz 47350 BLAKE2B 226481c73e66fb45a69b563bef9f95c6a04b782072643fd8e66e4da4907f899a72e2b4e1217b46c3a1f417bf9e4be193c3528da09954808043e4abf47be4d5c2 SHA512 d718d9abe4fe0ea0e7453ed09e57de2a427cc450225cf2b56513d99af4b4218c3fe96ab08dcebd202b9ecf25a471bb7c67511262f35148dfe15684421be6d743
+EBUILD cmdliner-1.0.0.ebuild 1022 BLAKE2B 3b948b63af7bd1024c33649cb7ff517a9c375574928323bfbc0aefbc49baee56b6441e3f08608dddb0be7ad52617bc28780fc73ef2266e08e1921f82d6a4e31b SHA512 701c1e4ae603a4131dd19020e8e50f89107cc59270cb37ee9fa27dd7c9f3095540b99b7344eee3b0fa85138970d9488a4597037d2336322b0dada3803f8b709f
+EBUILD cmdliner-1.0.1.ebuild 1022 BLAKE2B 3b948b63af7bd1024c33649cb7ff517a9c375574928323bfbc0aefbc49baee56b6441e3f08608dddb0be7ad52617bc28780fc73ef2266e08e1921f82d6a4e31b SHA512 701c1e4ae603a4131dd19020e8e50f89107cc59270cb37ee9fa27dd7c9f3095540b99b7344eee3b0fa85138970d9488a4597037d2336322b0dada3803f8b709f
+EBUILD cmdliner-1.0.2.ebuild 1022 BLAKE2B 3b948b63af7bd1024c33649cb7ff517a9c375574928323bfbc0aefbc49baee56b6441e3f08608dddb0be7ad52617bc28780fc73ef2266e08e1921f82d6a4e31b SHA512 701c1e4ae603a4131dd19020e8e50f89107cc59270cb37ee9fa27dd7c9f3095540b99b7344eee3b0fa85138970d9488a4597037d2336322b0dada3803f8b709f
+MISC metadata.xml 243 BLAKE2B 010ca240ae06e9a9f6d7ba213eb06df36d9ba862ff2d2458d98a9fea1a1e7f3026d13832a73bce1b3ad9345029425e6abfae9e03bf126f2329b3f030ed3753fd SHA512 1c5b4b2163017e496999d1f87e5c9c5ac6c11b2e9187450ccfb3df258f34e54d278972f04ee0e8429476c6f87e091a869ac2a28c6e8c8e6d20678c3e74061449
diff --git a/dev-ml/cmdliner/cmdliner-1.0.0.ebuild b/dev-ml/cmdliner/cmdliner-1.0.0.ebuild
new file mode 100644
index 000000000000..262192ca7b53
--- /dev/null
+++ b/dev-ml/cmdliner/cmdliner-1.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Declarative definition of command line interfaces for OCaml"
+HOMEPAGE="http://erratique.ch/software/cmdliner"
+SRC_URI="http://erratique.ch/software/${PN}/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="+ocamlopt test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4:=[ocamlopt?]
+ dev-ml/result:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/topkg
+ dev-ml/ocamlbuild"
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ --tests $(usex test true false) \
+ || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}
+
+src_install() {
+ # Can't use opam-installer here as it is an opam dep...
+ findlib_src_preinst
+ local nativelibs=""
+ use ocamlopt && nativelibs="$(echo _build/src/cmdliner.cm{x,xa,xs} _build/src/cmdliner.a)"
+ ocamlfind install cmdliner _build/pkg/META \
+ _build/src/cmdliner.mli _build/src/cmdliner.cm{a,i} ${nativelibs} || die
+ dodoc README.md CHANGES.md
+}
diff --git a/dev-ml/cmdliner/cmdliner-1.0.1.ebuild b/dev-ml/cmdliner/cmdliner-1.0.1.ebuild
new file mode 100644
index 000000000000..262192ca7b53
--- /dev/null
+++ b/dev-ml/cmdliner/cmdliner-1.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Declarative definition of command line interfaces for OCaml"
+HOMEPAGE="http://erratique.ch/software/cmdliner"
+SRC_URI="http://erratique.ch/software/${PN}/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="+ocamlopt test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4:=[ocamlopt?]
+ dev-ml/result:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/topkg
+ dev-ml/ocamlbuild"
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ --tests $(usex test true false) \
+ || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}
+
+src_install() {
+ # Can't use opam-installer here as it is an opam dep...
+ findlib_src_preinst
+ local nativelibs=""
+ use ocamlopt && nativelibs="$(echo _build/src/cmdliner.cm{x,xa,xs} _build/src/cmdliner.a)"
+ ocamlfind install cmdliner _build/pkg/META \
+ _build/src/cmdliner.mli _build/src/cmdliner.cm{a,i} ${nativelibs} || die
+ dodoc README.md CHANGES.md
+}
diff --git a/dev-ml/cmdliner/cmdliner-1.0.2.ebuild b/dev-ml/cmdliner/cmdliner-1.0.2.ebuild
new file mode 100644
index 000000000000..262192ca7b53
--- /dev/null
+++ b/dev-ml/cmdliner/cmdliner-1.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Declarative definition of command line interfaces for OCaml"
+HOMEPAGE="http://erratique.ch/software/cmdliner"
+SRC_URI="http://erratique.ch/software/${PN}/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="+ocamlopt test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4:=[ocamlopt?]
+ dev-ml/result:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/topkg
+ dev-ml/ocamlbuild"
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ --tests $(usex test true false) \
+ || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}
+
+src_install() {
+ # Can't use opam-installer here as it is an opam dep...
+ findlib_src_preinst
+ local nativelibs=""
+ use ocamlopt && nativelibs="$(echo _build/src/cmdliner.cm{x,xa,xs} _build/src/cmdliner.a)"
+ ocamlfind install cmdliner _build/pkg/META \
+ _build/src/cmdliner.mli _build/src/cmdliner.cm{a,i} ${nativelibs} || die
+ dodoc README.md CHANGES.md
+}
diff --git a/dev-ml/cmdliner/metadata.xml b/dev-ml/cmdliner/metadata.xml
new file mode 100644
index 000000000000..ffac4d7ebc01
--- /dev/null
+++ b/dev-ml/cmdliner/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>