summaryrefslogtreecommitdiff
path: root/dev-ml/cinaps/cinaps-0.15.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-ml/cinaps/cinaps-0.15.0.ebuild
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-ml/cinaps/cinaps-0.15.0.ebuild')
-rw-r--r--dev-ml/cinaps/cinaps-0.15.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ml/cinaps/cinaps-0.15.0.ebuild b/dev-ml/cinaps/cinaps-0.15.0.ebuild
new file mode 100644
index 000000000000..beef48458589
--- /dev/null
+++ b/dev-ml/cinaps/cinaps-0.15.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Trivial metaprogramming tool"
+HOMEPAGE="https://github.com/ocaml-ppx/cinaps"
+SRC_URI="https://github.com/ocaml-ppx/cinaps/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-ml/re:="
+RDEPEND="${DEPEND}"
+BDEPEND="
+ test? (
+ dev-ml/ppx_jane
+ )
+"