summaryrefslogtreecommitdiff
path: root/dev-ml/camomile/camomile-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-18 05:54:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-18 05:54:20 +0100
commit5a1fb66df455454109e1de61d38b48f509dc68b8 (patch)
tree0213f12db1b0138bffda43d11208c5d701967638 /dev-ml/camomile/camomile-2.0.0.ebuild
parent3a8423ee2874c2fd96358b28af08d38d83e9bdc0 (diff)
gentoo auto-resync : 18:04:2023 - 05:54:20
Diffstat (limited to 'dev-ml/camomile/camomile-2.0.0.ebuild')
-rw-r--r--dev-ml/camomile/camomile-2.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/camomile/camomile-2.0.0.ebuild b/dev-ml/camomile/camomile-2.0.0.ebuild
new file mode 100644
index 000000000000..333db6f3ae41
--- /dev/null
+++ b/dev-ml/camomile/camomile-2.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Camomile is a comprehensive Unicode library for ocaml"
+HOMEPAGE="https://github.com/savonet/Camomile"
+SRC_URI="https://github.com/savonet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P^}"
+
+LICENSE="LGPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+# Unbound module errors
+RESTRICT="test"
+
+RDEPEND="
+ dev-ml/dune-site:=
+ dev-ml/camlp-streams:=
+"
+DEPEND="${RDEPEND}"