summaryrefslogtreecommitdiff
path: root/dev-ml/camlp5/camlp5-8.02.00-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-01 00:07:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-01 00:07:06 +0100
commit1551fe56fd6ba43a94509cffc61b6bf854b7ac9f (patch)
treebe99b6ceb874878a108d68c641b476a2df076517 /dev-ml/camlp5/camlp5-8.02.00-r1.ebuild
parent0e2a727aba684f1a44cc0402a3f77d242140681b (diff)
gentoo auto-resync : 01:06:2024 - 00:07:06
Diffstat (limited to 'dev-ml/camlp5/camlp5-8.02.00-r1.ebuild')
-rw-r--r--dev-ml/camlp5/camlp5-8.02.00-r1.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-ml/camlp5/camlp5-8.02.00-r1.ebuild b/dev-ml/camlp5/camlp5-8.02.00-r1.ebuild
new file mode 100644
index 000000000000..e984b76b319f
--- /dev/null
+++ b/dev-ml/camlp5/camlp5-8.02.00-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit findlib vcs-clean
+
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="https://camlp5.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc +ocamlopt"
+
+RDEPEND="
+ dev-ml/astring:=
+ dev-ml/bos:=
+ dev-ml/camlp-streams:=
+ dev-ml/fmt:=
+ dev-ml/fpath:=
+ dev-ml/logs:=
+ dev-ml/pcre-ocaml:=
+ dev-ml/re:=
+ dev-ml/rresult:=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ egit_clean
+ default
+}
+
+src_configure() {
+ ./configure \
+ --strict \
+ -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man || die "configure failed"
+}
+
+src_compile() {
+ ulimit -s 11530000
+ emake out
+ if use ocamlopt; then
+ emake opt
+ emake opt.opt
+ fi
+}
+
+src_test() {
+ emake bootstrap
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ # findlib support
+ insinto "$(ocamlfind printconf destdir)/${PN}"
+ doins etc/META
+
+ dodoc -r doc/*
+ dodoc CHANGES DEVEL ICHANGES README.md UPGRADING MODE
+}