summaryrefslogtreecommitdiff
path: root/dev-ml/camlp5/camlp5-8.00.03.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-03 08:05:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-03 08:05:42 +0100
commit8435c842b9e8fbb2bcc80397ab3aa655000459e2 (patch)
treeb74558e80643a8f074c501e8b4bf7f50f7155455 /dev-ml/camlp5/camlp5-8.00.03.ebuild
parent5c5e9714c851027611cb726a76ebb8be6d48cbdc (diff)
gentoo auto-resync : 03:07:2024 - 08:05:42
Diffstat (limited to 'dev-ml/camlp5/camlp5-8.00.03.ebuild')
-rw-r--r--dev-ml/camlp5/camlp5-8.00.03.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-ml/camlp5/camlp5-8.00.03.ebuild b/dev-ml/camlp5/camlp5-8.00.03.ebuild
deleted file mode 100644
index 51e1576dbe88..000000000000
--- a/dev-ml/camlp5/camlp5-8.00.03.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit findlib vcs-clean
-
-DESCRIPTION="A preprocessor-pretty-printer of ocaml"
-HOMEPAGE="https://camlp5.github.io/"
-SRC_URI="https://github.com/camlp5/camlp5/archive/rel${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-rel${PV}"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-IUSE="doc +ocamlopt"
-
-RDEPEND="dev-ml/camlp-streams:="
-
-src_prepare() {
- egit_clean
- default
-}
-
-src_configure() {
- ./configure \
- --strict \
- -prefix /usr \
- -bindir /usr/bin \
- -libdir /usr/$(get_libdir)/ocaml \
- -mandir /usr/share/man || die "configure failed"
-}
-
-src_compile() {
- ulimit -s 11530000
- emake out
- if use ocamlopt; then
- emake opt
- emake opt.opt
- fi
-}
-
-src_test() {
- emake bootstrap
-}
-
-src_install() {
- emake DESTDIR="${ED}" install
- # findlib support
- insinto "$(ocamlfind printconf destdir)/${PN}"
- doins etc/META
-
- dodoc -r doc/*
- dodoc CHANGES DEVEL ICHANGES README.md UPGRADING MODE
-}