summaryrefslogtreecommitdiff
path: root/dev-ml/camlp4/camlp4-4.05_p1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /dev-ml/camlp4/camlp4-4.05_p1-r1.ebuild
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'dev-ml/camlp4/camlp4-4.05_p1-r1.ebuild')
-rw-r--r--dev-ml/camlp4/camlp4-4.05_p1-r1.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-ml/camlp4/camlp4-4.05_p1-r1.ebuild b/dev-ml/camlp4/camlp4-4.05_p1-r1.ebuild
index 7c3455031b75..fbeee42c3a43 100644
--- a/dev-ml/camlp4/camlp4-4.05_p1-r1.ebuild
+++ b/dev-ml/camlp4/camlp4-4.05_p1-r1.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
MY_PV=${PV/_p/+}
MY_P=${PN}-${MY_PV}
+
DESCRIPTION="System for writing extensible parsers for programming languages"
HOMEPAGE="https://github.com/camlp4/camlp4"
SRC_URI="https://github.com/camlp4/camlp4/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${P/_p/-}"
LICENSE="LGPL-2-with-linking-exception"
SLOT="0/${PV}"
@@ -17,9 +17,13 @@ IUSE="+ocamlopt"
RDEPEND="dev-lang/ocaml:0/$(ver_cut 1-2)[ocamlopt?]"
DEPEND="${RDEPEND}
- dev-ml/ocamlbuild
+ dev-ml/ocamlbuild[ocamlopt?]
dev-ml/findlib:="
+QA_FLAGS_IGNORED='.*'
+
+S="${WORKDIR}/${P/_p/-}"
+
src_configure() {
./configure \
--bindir="${EPREFIX}/usr/bin" \