summaryrefslogtreecommitdiff
path: root/dev-ml/camldbm/camldbm-1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-ml/camldbm/camldbm-1.0.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-ml/camldbm/camldbm-1.0.ebuild')
-rw-r--r--dev-ml/camldbm/camldbm-1.0.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-ml/camldbm/camldbm-1.0.ebuild b/dev-ml/camldbm/camldbm-1.0.ebuild
index 8f8d8b94854c..c025afbf93f0 100644
--- a/dev-ml/camldbm/camldbm-1.0.ebuild
+++ b/dev-ml/camldbm/camldbm-1.0.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="OCaml binding to the NDBM/GDBM Unix databases"
HOMEPAGE="http://forge.ocamlcore.org/projects/camldbm/"
SRC_URI="http://forge.ocamlcore.org/frs/download.php/728/${P}.tgz"
@@ -20,6 +22,14 @@ PATCHES=(
"${FILESDIR}/include_fix.patch"
)
+src_prepare() {
+ sed -i \
+ -e "s|ranlib|$(tc-getRANLIB)|g" \
+ Makefile \
+ || die
+ default
+}
+
src_install() {
dodir "$(ocamlc -where)/stublibs" # required and makefile does not create it
emake LIBDIR="${D}/$(ocamlc -where)" install