summaryrefslogtreecommitdiff
path: root/dev-ml/bos/bos-0.2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /dev-ml/bos/bos-0.2.0-r1.ebuild
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'dev-ml/bos/bos-0.2.0-r1.ebuild')
-rw-r--r--dev-ml/bos/bos-0.2.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ml/bos/bos-0.2.0-r1.ebuild b/dev-ml/bos/bos-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..b4f383fa7696
--- /dev/null
+++ b/dev-ml/bos/bos-0.2.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Basic OS interaction for OCaml"
+HOMEPAGE="https://erratique.ch/software/bos https://github.com/dbuenzli/bos"
+SRC_URI="https://erratique.ch/software/bos/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="amd64 arm arm64 ppc ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-lang/ocaml:=
+ dev-ml/rresult:=
+ dev-ml/astring:=
+ dev-ml/fpath:=
+ dev-ml/fmt:=
+ dev-ml/logs:=[fmt]"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-ml/findlib
+ dev-ml/ocamlbuild
+ dev-ml/topkg
+ test? ( dev-ml/mtime )"
+
+src_compile() {
+ ocaml pkg/pkg.ml build --tests $(usex test true false) || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}