summaryrefslogtreecommitdiff
path: root/dev-ml/bolt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/bolt
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/bolt')
-rw-r--r--dev-ml/bolt/Manifest3
-rw-r--r--dev-ml/bolt/bolt-1.4.ebuild40
-rw-r--r--dev-ml/bolt/metadata.xml8
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-ml/bolt/Manifest b/dev-ml/bolt/Manifest
new file mode 100644
index 000000000000..dc452f35dda5
--- /dev/null
+++ b/dev-ml/bolt/Manifest
@@ -0,0 +1,3 @@
+DIST bolt-1.4.tar.gz 638005 BLAKE2B 2d7c4266d3798b8f7d7c72ec6ea32324106fc845bfea1969538175225e74ff1e0bf65633bd1c5d260b4cf316f3216e32cfb1eab5ed61082ab56677e9de2141c2 SHA512 799ca80603fb4f0979ae7bf7ac5acdab7a0187713021a4277d5c3f5af31ffdea042ab312754a6d20a8849b90d36327aa0cad1d6efbc20cc07a3e86dd733e362e
+EBUILD bolt-1.4.ebuild 653 BLAKE2B 64e9b5700dcb2ce2b77bbbd67eb32375afcd24dc0d539119808e4c989ba01986a41871851a7f0abbb7d0dad88542c31fd3eb3d1a353f28c74217d4b6c7744f1e SHA512 afeb609fe52ac4a80f8fe2a7b92cf7b4d0bc568a4d763d1c8b88bc03c48fda9228f4696c166498e65a5b5a116e6487e035ca50a459a9489f767fd562183d00ff
+MISC metadata.xml 243 BLAKE2B 010ca240ae06e9a9f6d7ba213eb06df36d9ba862ff2d2458d98a9fea1a1e7f3026d13832a73bce1b3ad9345029425e6abfae9e03bf126f2329b3f030ed3753fd SHA512 1c5b4b2163017e496999d1f87e5c9c5ac6c11b2e9187450ccfb3df258f34e54d278972f04ee0e8429476c6f87e091a869ac2a28c6e8c8e6d20678c3e74061449
diff --git a/dev-ml/bolt/bolt-1.4.ebuild b/dev-ml/bolt/bolt-1.4.ebuild
new file mode 100644
index 000000000000..bc070efc1e0b
--- /dev/null
+++ b/dev-ml/bolt/bolt-1.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Logging tool for the Objective Caml language"
+HOMEPAGE="http://bolt.x9c.fr/"
+SRC_URI="http://bolt.x9c.fr/distrib/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt]
+ dev-ml/camlp4:="
+DEPEND="${RDEPEND}
+ dev-ml/ocamlbuild
+"
+
+src_configure() {
+ sh configure
+}
+
+src_compile() {
+ emake all
+ use doc && emake doc
+}
+
+src_test() {
+ emake tests
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README CHANGES FEATURES
+ use doc && dohtml ocamldoc/*
+}
diff --git a/dev-ml/bolt/metadata.xml b/dev-ml/bolt/metadata.xml
new file mode 100644
index 000000000000..ffac4d7ebc01
--- /dev/null
+++ b/dev-ml/bolt/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>