summaryrefslogtreecommitdiff
path: root/dev-ml/bolt/bolt-1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/bolt/bolt-1.4.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/bolt/bolt-1.4.ebuild')
-rw-r--r--dev-ml/bolt/bolt-1.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/bolt/bolt-1.4.ebuild b/dev-ml/bolt/bolt-1.4.ebuild
new file mode 100644
index 000000000000..bc070efc1e0b
--- /dev/null
+++ b/dev-ml/bolt/bolt-1.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Logging tool for the Objective Caml language"
+HOMEPAGE="http://bolt.x9c.fr/"
+SRC_URI="http://bolt.x9c.fr/distrib/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt]
+ dev-ml/camlp4:="
+DEPEND="${RDEPEND}
+ dev-ml/ocamlbuild
+"
+
+src_configure() {
+ sh configure
+}
+
+src_compile() {
+ emake all
+ use doc && emake doc
+}
+
+src_test() {
+ emake tests
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README CHANGES FEATURES
+ use doc && dohtml ocamldoc/*
+}