summaryrefslogtreecommitdiff
path: root/dev-ml/async_unix/async_unix-0.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/async_unix/async_unix-0.9.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/async_unix/async_unix-0.9.0.ebuild')
-rw-r--r--dev-ml/async_unix/async_unix-0.9.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/async_unix/async_unix-0.9.0.ebuild b/dev-ml/async_unix/async_unix-0.9.0.ebuild
new file mode 100644
index 000000000000..aac9eccd0f0a
--- /dev/null
+++ b/dev-ml/async_unix/async_unix-0.9.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Jane Street Capital's asynchronous execution library (unix)"
+HOMEPAGE="https://github.com/janestreet/async_unix"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02.0:=
+ dev-ml/async_kernel:=
+ dev-ml/core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_jane:=
+ dev-ml/ocaml-migrate-parsetree:=
+ <dev-ml/ppx_driver-100
+ <dev-ml/ppx_jane-100
+"
+DEPEND="${RDEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}