summaryrefslogtreecommitdiff
path: root/dev-ml/alcotest/alcotest-1.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-ml/alcotest/alcotest-1.5.0.ebuild
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-ml/alcotest/alcotest-1.5.0.ebuild')
-rw-r--r--dev-ml/alcotest/alcotest-1.5.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/alcotest/alcotest-1.5.0.ebuild b/dev-ml/alcotest/alcotest-1.5.0.ebuild
new file mode 100644
index 000000000000..d4924a1e4ea4
--- /dev/null
+++ b/dev-ml/alcotest/alcotest-1.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="A lightweight and colourful test framework"
+HOMEPAGE="https://github.com/mirage/alcotest/"
+SRC_URI="https://github.com/mirage/alcotest/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-ml/dune-2.8
+ dev-ml/astring:=
+ dev-ml/async_unix:=
+ dev-ml/cmdliner:=
+ dev-ml/core:=
+ dev-ml/core_kernel:=
+ dev-ml/duration:=
+ >=dev-ml/fmt-0.8.9:=
+ dev-ml/mirage-clock:=
+ dev-ml/re:=
+ dev-ml/result:=
+ dev-ml/logs:=
+ dev-ml/uutf:=
+ dev-ml/uuidm:=
+"
+DEPEND="${RDEPEND}"