summaryrefslogtreecommitdiff
path: root/dev-ml/alcotest/alcotest-1.4.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-24 22:45:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-24 22:45:43 +0000
commit3f6b99c9f74a0a7bfa2e18f0a7bc7057739cc00b (patch)
treee56393aac5dcc184833b4e155d45468003757d48 /dev-ml/alcotest/alcotest-1.4.0-r1.ebuild
parentb0fd0bc5c186e99078ed8d07146e8c14f1089639 (diff)
gentoo auto-resync : 24:01:2024 - 22:45:43
Diffstat (limited to 'dev-ml/alcotest/alcotest-1.4.0-r1.ebuild')
-rw-r--r--dev-ml/alcotest/alcotest-1.4.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/alcotest/alcotest-1.4.0-r1.ebuild b/dev-ml/alcotest/alcotest-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..dc71e978a2ab
--- /dev/null
+++ b/dev-ml/alcotest/alcotest-1.4.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="A lightweight and colourful test framework"
+HOMEPAGE="https://github.com/mirage/alcotest/"
+SRC_URI="https://github.com/mirage/alcotest/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/astring:=
+ dev-ml/async_unix:=
+ dev-ml/cmdliner:=
+ <dev-ml/core-0.15:=
+ dev-ml/core_kernel:=
+ dev-ml/duration:=
+ >=dev-ml/fmt-0.8.9:=
+ dev-ml/lwt:=
+ dev-ml/mirage-clock:=
+ dev-ml/re:=
+ dev-ml/result:=
+ dev-ml/logs:=
+ dev-ml/uutf:=
+ dev-ml/uuidm:=
+"
+DEPEND="${RDEPEND}"