summaryrefslogtreecommitdiff
path: root/dev-ml/alcotest/alcotest-0.8.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/alcotest/alcotest-0.8.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/alcotest/alcotest-0.8.2.ebuild')
-rw-r--r--dev-ml/alcotest/alcotest-0.8.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/alcotest/alcotest-0.8.2.ebuild b/dev-ml/alcotest/alcotest-0.8.2.ebuild
new file mode 100644
index 000000000000..40aa58ad9a07
--- /dev/null
+++ b/dev-ml/alcotest/alcotest-0.8.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit opam
+
+DESCRIPTION="A lightweight and colourful test framework"
+HOMEPAGE="https://github.com/mirage/alcotest/"
+SRC_URI="https://github.com/mirage/alcotest/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-ml/fmt:=
+ dev-ml/astring:=
+ dev-ml/cmdliner:=
+ dev-ml/result:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder
+ dev-ml/findlib"
+
+src_compile() {
+ jbuilder build -p alcotest || die
+}
+
+src_test() {
+ jbuilder runtest -p alcotest || die
+}