summaryrefslogtreecommitdiff
path: root/dev-lua/luvit/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-lua/luvit/files
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-lua/luvit/files')
-rw-r--r--dev-lua/luvit/files/luvit-0.7.0-unbundle-http-parser.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-lua/luvit/files/luvit-0.7.0-unbundle-http-parser.patch b/dev-lua/luvit/files/luvit-0.7.0-unbundle-http-parser.patch
new file mode 100644
index 000000000000..d9ae8568c140
--- /dev/null
+++ b/dev-lua/luvit/files/luvit-0.7.0-unbundle-http-parser.patch
@@ -0,0 +1,54 @@
+commit b34b7b0474878d1951637b762c68694c16c1c574
+Author: hasufell <hasufell@gentoo.org>
+Date: Sun Jun 30 22:37:10 2013 +0200
+
+ unbundle http-parser
+
+diff --git a/Makefile b/Makefile
+index a0e9277..99535ca 100644
+--- a/Makefile
++++ b/Makefile
+@@ -40,6 +40,7 @@ USE_SYSTEM_SSL?=0
+ USE_SYSTEM_LUAJIT?=0
+ USE_SYSTEM_ZLIB?=0
+ USE_SYSTEM_YAJL?=0
++USE_SYSTEM_HTTPPARSER?=0
+
+ DEBUG ?= 1
+ ifeq (${DEBUG},1)
+@@ -95,6 +96,10 @@ endif
+ LIBS += ${UVDIR}/libuv.a
+ LIBS += ${CARESDIR}/libcares.a
+
++ifeq (${USE_SYSTEM_HTTPPARSER},1)
++LIBS += -lhttp_parser
++endif
++
+ ifeq (${USE_SYSTEM_LUAJIT},1)
+ CPPFLAGS+=$(shell pkg-config --cflags luajit)
+ LIBS+=$(shell pkg-config --libs luajit)
+@@ -174,8 +179,11 @@ LUVLIBS=${BUILDDIR}/utils.o \
+ ${BUILDDIR}/lhttp_parser.o
+
+ DEPS= ${UVDIR}/libuv.a \
+- ${CARESDIR}/libcares.a \
+- ${HTTPDIR}/http_parser.o
++ ${CARESDIR}/libcares.a
++
++ifeq (${USE_SYSTEM_HTTPPARSER},0)
++DEPS += ${HTTPDIR}/http_parser.o
++endif
+
+ ifeq (${USE_SYSTEM_LUAJIT},0)
+ DEPS+=${LUADIR}/src/libluajit.a
+@@ -290,8 +298,10 @@ install: all
+ install ${BUILDDIR}/luvit ${BINDIR}/luvit
+ mkdir -p ${LIBDIR}
+ cp lib/luvit/*.lua ${LIBDIR}
++ifeq (${USE_SYSTEM_HTTPPARSER},0)
+ mkdir -p ${INCDIR}/http_parser
+ cp ${HTTPDIR}/http_parser.h ${INCDIR}/http_parser/
++endif
+ mkdir -p ${INCDIR}/uv
+ cp -r ${UVDIR}/include/* ${INCDIR}/uv/
+ cp src/*.h ${INCDIR}/