summaryrefslogtreecommitdiff
path: root/dev-lua/luarocks/luarocks-2.0.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-lua/luarocks/luarocks-2.0.7.1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-lua/luarocks/luarocks-2.0.7.1.ebuild')
-rw-r--r--dev-lua/luarocks/luarocks-2.0.7.1.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-lua/luarocks/luarocks-2.0.7.1.ebuild b/dev-lua/luarocks/luarocks-2.0.7.1.ebuild
deleted file mode 100644
index 85009d19c02c..000000000000
--- a/dev-lua/luarocks/luarocks-2.0.7.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils multilib
-
-DESCRIPTION="A deployment and management system for Lua modules"
-HOMEPAGE="http://www.luarocks.org"
-SRC_URI="http://luarocks.org/releases/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="curl openssl"
-
-DEPEND="dev-lang/lua
- curl? ( net-misc/curl )
- openssl? ( dev-libs/openssl )"
-RDEPEND="${DEPEND}
- app-arch/unzip"
-
-src_configure() {
- USE_MD5="md5sum"
- USE_FETCH="wget"
- use openssl && USE_MD5="openssl"
- use curl && USE_FETCH="curl"
-
- # econf doesn't work b/c it passes variables the custom configure can't
- # handle
- ./configure \
- --prefix=/usr \
- --with-lua-lib=/usr/$(get_libdir) \
- --rocks-tree=/usr/$(get_libdir)/lua/luarocks \
- --with-downloader=$USE_FETCH \
- --with-md5-checker=$USE_MD5 \
- --force-config || die "configure failed"
-}
-
-src_compile() {
- emake DESTDIR="${D}" || die "make failed"
-}
-
-src_install() {
- # -j1 b/c otherwise it fails with to find src/bin/luarocks
- emake DESTDIR="${D}" -j1 install || die "einstall"
-}
-
-pkg_preinst() {
- find "${D}" -type f | xargs sed -i -e "s:${D}::g" || die "sed failed"
-}