summaryrefslogtreecommitdiff
path: root/dev-lua/luaossl/luaossl-20180708.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /dev-lua/luaossl/luaossl-20180708.ebuild
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'dev-lua/luaossl/luaossl-20180708.ebuild')
-rw-r--r--dev-lua/luaossl/luaossl-20180708.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-lua/luaossl/luaossl-20180708.ebuild b/dev-lua/luaossl/luaossl-20180708.ebuild
new file mode 100644
index 000000000000..fd7565276080
--- /dev/null
+++ b/dev-lua/luaossl/luaossl-20180708.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P=${PN}-rel-${PV}
+DESCRIPTION="Most comprehensive OpenSSL module in the Lua universe."
+HOMEPAGE="https://github.com/wahern/luaossl"
+SRC_URI="https://github.com/wahern/luaossl/archive/rel-${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="luajit"
+
+RDEPEND="
+ luajit? ( dev-lang/luajit:2 )
+ !luajit? ( >=dev-lang/lua-5.1:0 )
+ dev-libs/openssl:0[-bindist]
+ !dev-lua/lua-openssl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ LUA_VERSION="$($(tc-getPKG_CONFIG) --variable=$(usex luajit abiver V) $(usex luajit luajit lua))"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" prefix="${EPREFIX}/usr" openssl${LUA_VERSION}
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" install${LUA_VERSION}
+}