summaryrefslogtreecommitdiff
path: root/dev-lua/luaevent/luaevent-0.4.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-lua/luaevent/luaevent-0.4.6-r1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-lua/luaevent/luaevent-0.4.6-r1.ebuild')
-rw-r--r--dev-lua/luaevent/luaevent-0.4.6-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-lua/luaevent/luaevent-0.4.6-r1.ebuild b/dev-lua/luaevent/luaevent-0.4.6-r1.ebuild
new file mode 100644
index 000000000000..8088a451e565
--- /dev/null
+++ b/dev-lua/luaevent/luaevent-0.4.6-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Binding of libevent for Lua"
+HOMEPAGE="http://luaforge.net/projects/luaevent"
+SRC_URI="https://github.com/harningt/luaevent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="
+ ${LUA_DEPS}
+ dev-libs/libevent:0=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ local mysedargs=(
+ -e "'s/CFLAGS =/CFLAGS +=/'"
+ -e "'s/LDFLAGS =/LDFLAGS +=/'"
+ -e "'s:-I\$(LUA_INC_DIR):\$(LUA_INC_DIR):'"
+ -i Makefile
+ )
+
+ eval sed ${mysedargs[@]} || die
+}
+
+lua_src_compile() {
+ tc-export CC
+
+ emake LUA_INC_DIR="$(lua_get_CFLAGS)"
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_install() {
+ local myemakeargs=(
+ DESTDIR="${ED}"
+ INSTALL_DIR_BIN="$(lua_get_cmod_dir)"
+ INSTALL_DIR_LUA="$(lua_get_lmod_dir)"
+ LUA_INC_DIR="$(lua_get_CFLAGS)"
+ )
+
+ emake ${myemakeargs[@]} install
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+}