summaryrefslogtreecommitdiff
path: root/dev-lua/luaevent/luaevent-0.4.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-lua/luaevent/luaevent-0.4.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-lua/luaevent/luaevent-0.4.3.ebuild')
-rw-r--r--dev-lua/luaevent/luaevent-0.4.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-lua/luaevent/luaevent-0.4.3.ebuild b/dev-lua/luaevent/luaevent-0.4.3.ebuild
new file mode 100644
index 000000000000..cd7a3d5f2bc5
--- /dev/null
+++ b/dev-lua/luaevent/luaevent-0.4.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit toolchain-funcs
+
+DESCRIPTION="libevent bindings for Lua"
+HOMEPAGE="http://luaforge.net/projects/luaevent"
+SRC_URI="https://github.com/harningt/luaevent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/lua-5.1
+ >=dev-libs/libevent-1.4"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i "s:^CFLAGS =:CFLAGS +=:" "${S}/Makefile" \
+ || die "sed failed"
+ sed -i "s:^LDFLAGS =:LDFLAGS +=:" "${S}/Makefile" \
+ || die "sed failed"
+ sed -i "/^LDFLAGS/a CC = $(tc-getCC)" "${S}/Makefile" \
+ || die "sed failed"
+ sed -i "s:^LUA_INC_DIR ?=.*:LUA_INC_DIR ?= $(pkg-config --variable INSTALL_INC lua):" "${S}/Makefile" \
+ || die "sed failed"
+ sed -i "s:^INSTALL_DIR_LUA ?=.*:INSTALL_DIR_LUA ?= $(pkg-config --variable INSTALL_LMOD lua):" "${S}/Makefile" \
+ || die "sed failed"
+ sed -i "s:^INSTALL_DIR_BIN ?=.*:INSTALL_DIR_BIN ?= $(pkg-config --variable INSTALL_CMOD lua):" "${S}/Makefile" \
+ || die "sed failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+}