summaryrefslogtreecommitdiff
path: root/dev-lua/luacrypto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-lua/luacrypto
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-lua/luacrypto')
-rw-r--r--dev-lua/luacrypto/Manifest4
-rw-r--r--dev-lua/luacrypto/files/luacrypto-0.3.2-lualibdir.patch11
-rw-r--r--dev-lua/luacrypto/luacrypto-0.3.2-r1.ebuild39
-rw-r--r--dev-lua/luacrypto/metadata.xml8
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-lua/luacrypto/Manifest b/dev-lua/luacrypto/Manifest
new file mode 100644
index 000000000000..921d130bc971
--- /dev/null
+++ b/dev-lua/luacrypto/Manifest
@@ -0,0 +1,4 @@
+AUX luacrypto-0.3.2-lualibdir.patch 299 BLAKE2B 83ec7d532aff1109b78e659abd33bf1df4eae736b3e1018f5283c74ec11be0e79b5d08354d979ae17c2d9da7426295190b203ff01d6c004de6cfde202a0bead9 SHA512 cef182827a67229396dc53f0980829065f83fdd3a1bb6069e452b3945bd74459898954a2f1b3f9ada1d3834388446a720a3d24a1f070efdb814227ad94ea6735
+DIST luacrypto-0.3.2.tar.gz 374363 BLAKE2B 043ef787f9b99f7d25bfa9a96d2495f2bfbeec0200c956b978cfc003c51f0faba99848bf290e011a3f8ba8a50d99bf5b6f9b5346addcd57f71978a4af8f4117d SHA512 4cb20d2cc348a11f140210dffb803629034c72cc7232590f4488f559d5c7233e0c41e56fcd0863959ac0b07e64c9aa79ea573e4126fdc11bc3f1b3b49d13343e
+EBUILD luacrypto-0.3.2-r1.ebuild 778 BLAKE2B 780f423615cbd7f3a35967e34ea5b97e70782fdf7b46bc2323a673cd1018c60417fbaa2e92faa907dff410787f7b7a1c8f97ac39c83842ed9cc0f5f69be3c66a SHA512 eab4d0b16f1aeb932446c9dd5d00387934b9f93cc467923a2f2109cf8e01d7ca10b8b32796ebdadd0b5208e482d396b2da85482be58b27ad5e3b5e7305d4a492
+MISC metadata.xml 255 BLAKE2B 2bf4f730b919a8331ebff73c5bfcf38c49a55714816935d0ad50d95736da91b3984399501e02ad6d50a6bba120cc0c1e70b115e3704215f589616994e23e305a SHA512 2cac273dcf66f34dd2c722aebdac845b9e22f513915d2ad8a0cf7e850b343bbf2724ae8dfe151b49dc57a87c85214d70e4ec081237e8ce8ba2c7d9dcd1675ce3
diff --git a/dev-lua/luacrypto/files/luacrypto-0.3.2-lualibdir.patch b/dev-lua/luacrypto/files/luacrypto-0.3.2-lualibdir.patch
new file mode 100644
index 000000000000..461e066865c2
--- /dev/null
+++ b/dev-lua/luacrypto/files/luacrypto-0.3.2-lualibdir.patch
@@ -0,0 +1,11 @@
+--- luacrypto-0.3.2/configure.ac
++++ luacrypto-0.3.2/configure.ac
+@@ -31,7 +31,7 @@
+ PKG_CHECK_MODULES([LUA], [lua])
+
+ # lua libdir
+-LUALIBDIR="`$PKGCONFIG --variable=libdir lua`"
++LUALIBDIR="`$PKGCONFIG --variable=INSTALL_CMOD lua`"
+
+ # dest of headers
+ CRYPTOINC="${includedir}/${PACKAGE_NAME}"
diff --git a/dev-lua/luacrypto/luacrypto-0.3.2-r1.ebuild b/dev-lua/luacrypto/luacrypto-0.3.2-r1.ebuild
new file mode 100644
index 000000000000..2166a46878b5
--- /dev/null
+++ b/dev-lua/luacrypto/luacrypto-0.3.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="Lua frontend to OpenSSL"
+HOMEPAGE="http://mkottman.github.io/luacrypto/ https://github.com/mkottman/luacrypto/"
+SRC_URI="https://github.com/mkottman/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl"
+
+RDEPEND="
+ >=dev-lang/lua-5.1:0
+ !libressl? ( dev-libs/openssl:0 ) libressl? ( dev-libs/libressl:0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-lualibdir.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf --htmldir=/usr/share/doc/${PF}/html
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}
diff --git a/dev-lua/luacrypto/metadata.xml b/dev-lua/luacrypto/metadata.xml
new file mode 100644
index 000000000000..b6155ce2e922
--- /dev/null
+++ b/dev-lua/luacrypto/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">mkottman/luacrypto</remote-id>
+ </upstream>
+</pkgmetadata>