summaryrefslogtreecommitdiff
path: root/dev-lua/luacov/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-lua/luacov/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-lua/luacov/files')
-rw-r--r--dev-lua/luacov/files/luacov-0.8-fix-makefile.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-lua/luacov/files/luacov-0.8-fix-makefile.patch b/dev-lua/luacov/files/luacov-0.8-fix-makefile.patch
new file mode 100644
index 000000000000..7a4ea6ba9ea7
--- /dev/null
+++ b/dev-lua/luacov/files/luacov-0.8-fix-makefile.patch
@@ -0,0 +1,25 @@
+diff --git a/Makefile b/Makefile
+index 477f9de..adad2cc 100644
+--- a/Makefile
++++ b/Makefile
+@@ -6,13 +6,13 @@ BINDIR=$(PREFIX)/bin
+ LUADIR=$(PREFIX)/share/lua/5.1/
+
+ install:
+- mkdir -p $(BINDIR)
+- cp src/bin/luacov $(BINDIR)
+- chmod +x $(BINDIR)/luacov
+- mkdir -p $(LUADIR)
+- cp src/luacov.lua $(LUADIR)
+- mkdir -p $(LUADIR)/luacov
+- cp src/luacov/*.lua $(LUADIR)/luacov
++ mkdir -p $(DESTDIR)$(BINDIR)
++ cp src/bin/luacov $(DESTDIR)$(BINDIR)
++ chmod +x $(DESTDIR)$(BINDIR)/luacov
++ mkdir -p $(DESTDIR)$(LUADIR)
++ cp src/luacov.lua $(DESTDIR)$(LUADIR)
++ mkdir -p $(DESTDIR)$(LUADIR)/luacov
++ cp src/luacov/*.lua $(DESTDIR)$(LUADIR)/luacov
+
+ dist:
+ rm -rf $(PACKAGE)-$(VERSION)