summaryrefslogtreecommitdiff
path: root/dev-lua/luacheck/luacheck-0.20.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-lua/luacheck/luacheck-0.20.0-r1.ebuild
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-lua/luacheck/luacheck-0.20.0-r1.ebuild')
-rw-r--r--dev-lua/luacheck/luacheck-0.20.0-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-lua/luacheck/luacheck-0.20.0-r1.ebuild b/dev-lua/luacheck/luacheck-0.20.0-r1.ebuild
new file mode 100644
index 000000000000..857d9ef215df
--- /dev/null
+++ b/dev-lua/luacheck/luacheck-0.20.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="A tool for linting and static analysis of Lua code"
+HOMEPAGE="https://github.com/mpeterv/luacheck"
+SRC_URI="https://github.com/mpeterv/luacheck/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ppc64 x86"
+IUSE="doc luajit test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lua/luafilesystem[luajit(-)=]
+ !luajit? ( >=dev-lang/lua-5.1:0= )
+ luajit? ( dev-lang/luajit:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx )
+ test? ( dev-lua/busted )"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_compile() {
+ if use doc; then
+ sphinx-build docsrc html || die
+ fi
+}
+
+src_test() {
+ busted -o gtest || die
+}
+
+src_install() {
+ local instdir
+ instdir="$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD $(usex luajit 'luajit' 'lua'))"
+ insinto "${instdir#${EPREFIX}}"
+ doins -r src/luacheck
+
+ newbin bin/luacheck.lua luacheck
+
+ use doc && HTML_DOCS+=( html/. )
+
+ einstalldocs
+}