summaryrefslogtreecommitdiff
path: root/dev-lua/lua-argparse/lua-argparse-0.7.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-lua/lua-argparse/lua-argparse-0.7.1-r1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-lua/lua-argparse/lua-argparse-0.7.1-r1.ebuild')
-rw-r--r--dev-lua/lua-argparse/lua-argparse-0.7.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-lua/lua-argparse/lua-argparse-0.7.1-r1.ebuild b/dev-lua/lua-argparse/lua-argparse-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..a5ec5f1a7f61
--- /dev/null
+++ b/dev-lua/lua-argparse/lua-argparse-0.7.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Feature-rich command line parser for Lua"
+HOMEPAGE="https://github.com/luarocks/argparse"
+SRC_URI="https://github.com/luarocks/${PN/lua-/}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN//lua-/}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+lua_src_install() {
+ insinto "$(lua_get_lmod_dir)"
+ doins src/argparse.lua
+}
+
+src_install() {
+ default
+ lua_foreach_impl lua_src_install
+}