summaryrefslogtreecommitdiff
path: root/dev-lua/lpeg/lpeg-1.0.2-r101.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /dev-lua/lpeg/lpeg-1.0.2-r101.ebuild
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'dev-lua/lpeg/lpeg-1.0.2-r101.ebuild')
-rw-r--r--dev-lua/lpeg/lpeg-1.0.2-r101.ebuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/dev-lua/lpeg/lpeg-1.0.2-r101.ebuild b/dev-lua/lpeg/lpeg-1.0.2-r101.ebuild
index 769fbe86123a..fd6789b18f6e 100644
--- a/dev-lua/lpeg/lpeg-1.0.2-r101.ebuild
+++ b/dev-lua/lpeg/lpeg-1.0.2-r101.ebuild
@@ -13,7 +13,7 @@ SRC_URI="http://www.inf.puc-rio.br/~roberto/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~mips ppc ppc64 sparc x86"
+KEYWORDS="amd64 arm arm64 ~hppa ~mips ppc ppc64 sparc x86 ~x64-macos"
IUSE="test debug doc"
REQUIRED_USE="${LUA_REQUIRED_USE}"
@@ -39,6 +39,11 @@ lua_src_prepare() {
src_prepare() {
default
use debug && append-cflags -DLPEG_DEBUG
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ append-ldflags "-undefined dynamic_lookup"
+ fi
+
lua_foreach_impl lua_src_prepare
}
@@ -70,6 +75,14 @@ lua_src_install() {
instdir="$(lua_get_lmod_dir)"
insinto "${instdir#${EPREFIX}}"
doins re.lua
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ local luav=$(lua_get_version)
+ # we only want the major version (e.g. 5.1)
+ local luamv=${luav:0:3}
+ local file="lua/${luamv}/lpeg.so"
+ install_name_tool -id "${EPREFIX}/usr/$(get_libdir)/${file}" "${ED}/usr/$(get_libdir)/${file}" || die "Failed to adjust install_name"
+ fi
}
src_install() {