summaryrefslogtreecommitdiff
path: root/dev-lisp/roswell/roswell-22.12.14.113.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-20 12:05:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-20 12:05:24 +0100
commitda7ae1dd1fccb6b3c0e4763ab983ad96d57bf463 (patch)
tree0a7a1b7b3ad60c3b21c697e75908b256fc9ed6b1 /dev-lisp/roswell/roswell-22.12.14.113.ebuild
parentb6cfc0c19effe2d9f7b8ab303cd00636f16da253 (diff)
gentoo auto-resync : 20:04:2024 - 12:05:23
Diffstat (limited to 'dev-lisp/roswell/roswell-22.12.14.113.ebuild')
-rw-r--r--dev-lisp/roswell/roswell-22.12.14.113.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-lisp/roswell/roswell-22.12.14.113.ebuild b/dev-lisp/roswell/roswell-22.12.14.113.ebuild
new file mode 100644
index 000000000000..e287f778cad6
--- /dev/null
+++ b/dev-lisp/roswell/roswell-22.12.14.113.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A lisp installer and launcher for major environment"
+HOMEPAGE="https://github.com/roswell/roswell"
+SRC_URI="https://github.com/roswell/roswell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+
+# File collision with librouteros (#691754)
+RDEPEND="!net-libs/librouteros
+ net-misc/curl"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}