summaryrefslogtreecommitdiff
path: root/dev-lisp/c2ffi/c2ffi-16.0.0.20231016.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-17 10:00:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-17 10:00:35 +0100
commitcf89ca044e37f79e2329552cda857215f9824e11 (patch)
treea6720b1db82c94482ed8a998aa77650c5f723358 /dev-lisp/c2ffi/c2ffi-16.0.0.20231016.ebuild
parentcb627578a344c874750e23e7eb59b1acc85aa639 (diff)
gentoo auto-resync : 17:10:2023 - 10:00:35
Diffstat (limited to 'dev-lisp/c2ffi/c2ffi-16.0.0.20231016.ebuild')
-rw-r--r--dev-lisp/c2ffi/c2ffi-16.0.0.20231016.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-lisp/c2ffi/c2ffi-16.0.0.20231016.ebuild b/dev-lisp/c2ffi/c2ffi-16.0.0.20231016.ebuild
new file mode 100644
index 000000000000..b698939cb9c6
--- /dev/null
+++ b/dev-lisp/c2ffi/c2ffi-16.0.0.20231016.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LLVM_MAX_SLOT=16
+inherit cmake llvm
+
+MY_COMMIT="040e6c0af132e9b315960178d9afdd9d4daaf345"
+
+DESCRIPTION="Clang-based FFI wrapper generator for Common Lisp"
+HOMEPAGE="https://github.com/rpav/c2ffi"
+SRC_URI="https://github.com/rpav/c2ffi/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/c2ffi-${MY_COMMIT}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="sys-devel/clang:${LLVM_MAX_SLOT}
+ sys-devel/llvm:${LLVM_MAX_SLOT}"
+RDEPEND="${DEPEND}"