summaryrefslogtreecommitdiff
path: root/dev-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-15 17:55:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-15 17:55:24 +0000
commit3392d5e937023e57811edc670b0ed7d3aba55c6d (patch)
tree32c103a9b86223dcc05105e88f05d471bcaf0886 /dev-libs
parent046c3c0984fd20387a9f86cdd0842fd81e70d94f (diff)
gentoo auto-resync : 15:01:2023 - 17:55:24
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/Manifest.gzbin96447 -> 96442 bytes
-rw-r--r--dev-libs/tre/Manifest1
-rw-r--r--dev-libs/tre/tre-0.8.0_p20210321-r2.ebuild106
3 files changed, 107 insertions, 0 deletions
diff --git a/dev-libs/Manifest.gz b/dev-libs/Manifest.gz
index b48ae668637e..d283719176f6 100644
--- a/dev-libs/Manifest.gz
+++ b/dev-libs/Manifest.gz
Binary files differ
diff --git a/dev-libs/tre/Manifest b/dev-libs/tre/Manifest
index dfae7a2d0317..490c283d6901 100644
--- a/dev-libs/tre/Manifest
+++ b/dev-libs/tre/Manifest
@@ -9,4 +9,5 @@ AUX tre-python3.patch 5186 BLAKE2B c9e08efa47fb8ad00385703c9c7cc9d240eaccacf472c
AUX tre-tests.patch 235 BLAKE2B 11c601f9b352dee9e2d36e60c537a4c2969beefd04bdab21c1e00886611d243a6c818b4a8cb484b8a414d3ec07de3e3ce32fde4aaa096bcda307b66225e8179b SHA512 69373229743ad805d4bfbf41def35de930424baaf66c36f35b3cba04860c2de15051ff640d486ec75e85aa20a28863e7937c6876ec443418ba1391e9dbbf4047
DIST tre-0.8.0_p20210321.tar.gz 146294 BLAKE2B d740bd0e99f50f5e4d8105f5260e43a81b6af9857a21e386e437ab8d48a9e0de23eae03e96cf6b9f4d2d37f72d0fa73ef7343086271ea80f166bdba3f04475a9 SHA512 950c81f681970fc737cfdd6815445f05a018fc742b964cea3ce19f0249c677dd715ece4ff8e543fa9f3fd23b503eafa00aea00dbae063af9bc7e08dc1bc33aed
EBUILD tre-0.8.0_p20210321-r1.ebuild 2403 BLAKE2B 0b631a238be1ec442760034fa209fc62754a68493bd4585a802be19dcfdb8546b7ab64743f15beb385c376271748442ad76c37f223062f13961738a1559783d2 SHA512 742e71d0677c0d285820cb26ede67c9adb8160dbd533b333c90686c1cf611547cc36fe094686d904125e2f2cf0ec1510a32e8e3ab3fa8226ba696b3c608a60a2
+EBUILD tre-0.8.0_p20210321-r2.ebuild 2182 BLAKE2B d063a1f9a818cf46cfe75d667ef2a4d4ac3258d771c5bee78d800f9b4be2b3a07fc0fc3ee51db9b9571ec2e3fab7373a4d501b83bfd1c9d53efd92d44f5e4932 SHA512 5987d873b55c4cb92c09789c9a93301e779857853fb35ce247b19c2f6d870e1ea4633de2863ecbc12c62d9fa66e3e165fad402c8878ad7e79d2f68e4eaca1edd
MISC metadata.xml 638 BLAKE2B 4e02f7673a19acc091ee21459551e6d40f6a78d5a25cbbffe877d46f0a181067e2163d1ac79d0f7d38ff383b8775abf6f69309ad97b25fd2af55b0ac2223ab40 SHA512 9f725eebbee4753cb05b0adcda1edec2aa50265257db359ca0ec4596761072ec335fffb5a5035cf5ec43c13b8c8a7dd7ed916bbf82acd57c6d8ee5e4c89cb622
diff --git a/dev-libs/tre/tre-0.8.0_p20210321-r2.ebuild b/dev-libs/tre/tre-0.8.0_p20210321-r2.ebuild
new file mode 100644
index 000000000000..7913295ee3a2
--- /dev/null
+++ b/dev-libs/tre/tre-0.8.0_p20210321-r2.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+COMMIT="6092368aabdd0dbb0fbceb2766a37b98e0ff6911"
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+DISTUTILS_OPTIONAL=1
+
+inherit autotools distutils-r1
+
+DESCRIPTION="Lightweight, robust, and efficient POSIX compliant regexp matching library"
+HOMEPAGE="
+ https://laurikari.net/tre/
+ https://github.com/laurikari/tre
+"
+SRC_URI="https://github.com/laurikari/tre/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="+agrep +alloca +approx debug nls profile python"
+
+RDEPEND="
+ agrep? (
+ !app-text/agrep
+ !dev-ruby/amatch
+ !app-misc/glimpse
+ )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+BDEPEND="
+ python? ( ${DISTUTILS_DEPS} )
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+REQUIRED_USE="
+ agrep? ( approx )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+PATCHES=(
+ "${FILESDIR}/0.8.0-pkgcfg.patch"
+ "${FILESDIR}/0.8.0-CVE-2016-8559.patch"
+ "${FILESDIR}/${PN}-chicken.patch"
+ "${FILESDIR}/${PN}-issue37.patch"
+ "${FILESDIR}/${PN}-issue50.patch"
+ "${FILESDIR}/${PN}-issue55-part1.patch"
+ "${FILESDIR}/${PN}-issue55-part2.patch"
+ "${FILESDIR}/${PN}-python3.patch"
+ "${FILESDIR}/${PN}-tests.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ --disable-system-abi
+ --enable-multibyte
+ --enable-wchar
+ $(use_enable agrep)
+ $(use_enable approx)
+ $(use_enable debug)
+ $(use_enable nls)
+ $(use_enable profile)
+ $(use_with alloca)
+ )
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ if locale -a | grep -iq en_US.iso88591; then
+ emake -j1 check
+ else
+ ewarn "If you like to run the test,"
+ ewarn "please make sure en_US.ISO-8859-1 is installed."
+ die "en_US.ISO-8859-1 locale is missing"
+ fi
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ cd python || die
+ distutils-r1_src_compile
+ fi
+}
+
+src_install() {
+ local HTML_DOCS=( doc/*.{css,html} )
+
+ default
+
+ use python && distutils-r1_src_install
+}