summaryrefslogtreecommitdiff
path: root/dev-libs/zziplib/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-libs/zziplib/files
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-libs/zziplib/files')
-rw-r--r--dev-libs/zziplib/files/zziplib-0.13.71-installing-man3-pages.patch25
1 files changed, 22 insertions, 3 deletions
diff --git a/dev-libs/zziplib/files/zziplib-0.13.71-installing-man3-pages.patch b/dev-libs/zziplib/files/zziplib-0.13.71-installing-man3-pages.patch
index 08130f958dda..55fb4be7a51c 100644
--- a/dev-libs/zziplib/files/zziplib-0.13.71-installing-man3-pages.patch
+++ b/dev-libs/zziplib/files/zziplib-0.13.71-installing-man3-pages.patch
@@ -1,9 +1,28 @@
-# https://github.com/gdraheim/zziplib/issues/93
diff --git a/docs/CMakeLists.txt b/docs/CMakeLists.txt
-index b679f7b..e2887ee 100644
+index b679f7b..cafa6b4 100644
--- a/docs/CMakeLists.txt
+++ b/docs/CMakeLists.txt
-@@ -190,7 +190,7 @@ add_custom_target(install-manpages
+@@ -126,9 +126,10 @@ add_custom_command(OUTPUT manpages.tar
+ COMMAND ${BASH} -c "test -d man3/man3 && mv man3 man3_; test -d man3_/man3 && mv man3_/man3 .; rm -rf man3_"
+ COMMAND ${BASH} -c "chmod 664 man3/*.3"
+ COMMAND ${BASH} -c "tar cf manpages.tar man3"
+- COMMAND ${BASH} -c "ls -l `pwd`/manpages.tar `pwd`/htmpages.tar >&2 || true"
++ COMMAND ${BASH} -c "ls -l `pwd`/manpages.tar >&2 || true"
+ DEPENDS zziplib.xml zzipmmapped.xml zzipfseeko.xml
+ VERBATIM)
++if(ZZIP_HTMPAGES)
+ add_custom_command(OUTPUT htmpages.tar
+ COMMAND ${BASH} -c "test -d html && rm -rf html; mkdir html"
+ COMMAND ${PY} ${srcdir}/dbk2man.py -o html html zziplib.xml
+@@ -139,6 +140,7 @@ add_custom_command(OUTPUT htmpages.tar
+ COMMAND ${BASH} -c "ls -l `pwd`/htmpages.tar `pwd`/manpages.tar >&2 || true"
+ DEPENDS zziplib.xml zzipmmapped.xml zzipfseeko.xml
+ VERBATIM)
++endif()
+
+ add_custom_target(manpages DEPENDS manpages.tar)
+ add_custom_target(htmpages DEPENDS htmpages.tar)
+@@ -190,7 +192,7 @@ if(ZZIP_HTMPAGES)
endif()
if(ZZIP_MANPAGES)
install(CODE "message(STATUS \"Installing: man3 pages to ${mandir}/man3\")")