summaryrefslogtreecommitdiff
path: root/dev-libs/zthread/zthread-2.3.2-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-libs/zthread/zthread-2.3.2-r4.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-libs/zthread/zthread-2.3.2-r4.ebuild')
-rw-r--r--dev-libs/zthread/zthread-2.3.2-r4.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/dev-libs/zthread/zthread-2.3.2-r4.ebuild b/dev-libs/zthread/zthread-2.3.2-r4.ebuild
index 02af2643693a..9d7decd68746 100644
--- a/dev-libs/zthread/zthread-2.3.2-r4.ebuild
+++ b/dev-libs/zthread/zthread-2.3.2-r4.ebuild
@@ -1,25 +1,23 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools eutils ltprune
+inherit autotools
MY_P="ZThread-${PV}"
DESCRIPTION="platform-independent multi-threading and synchronization library for C++"
HOMEPAGE="http://zthread.sourceforge.net/"
SRC_URI="mirror://sourceforge/zthread/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm64 ~hppa ~mips ppc ~sparc x86"
-IUSE="debug doc kernel_linux static-libs"
-
-DEPEND="doc? ( app-doc/doxygen )"
-RDEPEND=""
+IUSE="debug doc kernel_linux"
-S="${WORKDIR}/${MY_P}"
+BDEPEND="doc? ( app-doc/doxygen )"
PATCHES=(
"${FILESDIR}"/${P}-no-fpermissive-r1.diff
@@ -34,7 +32,8 @@ src_prepare() {
rm -f include/zthread/{.Barrier.h.swp,Barrier.h.orig} || die
- sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #467778
+ # bug #467778
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die
AT_M4DIR="share" eautoreconf
}
@@ -43,7 +42,7 @@ src_configure() {
econf \
$(use_enable debug) \
$(use_enable kernel_linux atomic-linux) \
- $(use_enable static-libs static)
+ --disable-static
}
src_compile() {
@@ -62,5 +61,5 @@ src_install() {
use doc && dodoc -r doc/html
- prune_libtool_files
+ find "${ED}" -name '*.la' -delete || die
}