summaryrefslogtreecommitdiff
path: root/dev-libs/zthread/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/zthread/files
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/zthread/files')
-rw-r--r--dev-libs/zthread/files/zthread-2.3.2-automake-r2.patch75
-rw-r--r--dev-libs/zthread/files/zthread-2.3.2-automake.patch45
-rw-r--r--dev-libs/zthread/files/zthread-2.3.2-clang.patch16
-rw-r--r--dev-libs/zthread/files/zthread-2.3.2-gcc47.patch25
-rw-r--r--dev-libs/zthread/files/zthread-2.3.2-m4-quote.patch26
-rw-r--r--dev-libs/zthread/files/zthread-2.3.2-no-fpermissive-r1.diff94
-rw-r--r--dev-libs/zthread/files/zthread-2.3.2-no-fpermissive.diff94
7 files changed, 375 insertions, 0 deletions
diff --git a/dev-libs/zthread/files/zthread-2.3.2-automake-r2.patch b/dev-libs/zthread/files/zthread-2.3.2-automake-r2.patch
new file mode 100644
index 000000000000..bcd9e0675979
--- /dev/null
+++ b/dev-libs/zthread/files/zthread-2.3.2-automake-r2.patch
@@ -0,0 +1,75 @@
+From 577b34b74b7a73650d906f371044bfaed6e8b74c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Tiziano=20M=C3=BCller?= <tm@dev-zero.ch>
+Date: Tue, 19 Feb 2013 10:13:12 +0100
+Subject: [PATCH] Use standard automake rules rather than hand coding the
+ install rules and append linker flags to LDFLAGS and not LDADD, otherwise
+ --as-needed gets ignored (and possibly others).
+
+---
+ Makefile.am | 21 +++++----------------
+ configure.ac | 1 -
+ src/Makefile.am | 2 --
+ 3 files changed, 5 insertions(+), 19 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 6c092cf..2d7bddf 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -24,24 +24,13 @@ LICENSE \
+ MIT.TXT \
+ depcomp
+
++bin_SCRIPTS = share/zthread-config
+
+-## install the config script
+-install-exec-hook:
+- $(mkinstalldirs) $(bindir)
+- $(INSTALL_PROGRAM) $(top_srcdir)/share/zthread-config $(bindir)
++aclocaldir = $(datadir)/aclocal
++aclocal_DATA = share/zthread.m4 share/pthread.m4
+
+-## install the config script & m4 macros
+-install-data-hook:
+- $(mkinstalldirs) $(datadir)/aclocal
+- $(INSTALL_DATA) $(top_srcdir)/share/zthread.m4 $(datadir)/aclocal
+- $(INSTALL_DATA) $(top_srcdir)/share/pthread.m4 $(datadir)/aclocal
+- mkdir -p $(DESTDIR)$(includedir)/zthread
+- cp -pR $(top_srcdir)/include/zthread $(DESTDIR)$(includedir)/
+-
+-## uninstall the config script & m4 macros
+-uninstall-local:
+- -rm -rf $(datadir)/aclocal/pthread.m4
+- -rm -rf $(datadir)/aclocal/zthread.m4
++zincludedir = $(includedir)/zthread
++zinclude_HEADERS = include/zthread/*.h
+
+ distclean-local:
+ -rm -rf $(top_srcdir)/$(PACKAGE)-$(VERSION).tar.gz
+diff --git a/configure.ac b/configure.ac
+index 866041b..5d32a58 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -226,7 +226,6 @@ AC_TRY_LINK( [#include <windows.h>], [_beginthreadex((void*)0, 0, 0, (void*)0, 0
+
+ dnl Configure the final compiler & linker options
+ COMPILER_OPTIONS="$COMPILER_OPTIONS $CXXFLAGS"
+-LINKER_OPTIONS="$LINKER_OPTIONS $LDFLAGS"
+
+ dnl Configured flags for compiling ZThreads
+ AC_SUBST(LINKER_OPTIONS)
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 04404d6..35dc764 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -21,8 +21,6 @@ AM_CXXFLAGS = @COMPILER_OPTIONS@ @EXTRA_COMPILER_OPTIONS@
+ INCLUDES = -I$(top_srcdir)/include
+ SUBDIRS=.
+
+-libdir=$(prefix)/lib
+-
+ lib_LTLIBRARIES = libZThread.la
+
+ libZThread_la_LIBADD=@LINKER_OPTIONS@ @EXTRA_LINKER_OPTIONS@
+--
+1.8.1.1
+
diff --git a/dev-libs/zthread/files/zthread-2.3.2-automake.patch b/dev-libs/zthread/files/zthread-2.3.2-automake.patch
new file mode 100644
index 000000000000..f2eae68c505b
--- /dev/null
+++ b/dev-libs/zthread/files/zthread-2.3.2-automake.patch
@@ -0,0 +1,45 @@
+use standard automake rules rather than hand coding the install rules
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -24,24 +24,13 @@
+ MIT.TXT \
+ depcomp
+
++bin_SCRIPTS = share/zthread-config
+
+-## install the config script
+-install-exec-hook:
+- $(mkinstalldirs) $(bindir)
+- $(INSTALL_PROGRAM) $(top_srcdir)/share/zthread-config $(bindir)
++aclocaldir = $(datadir)/aclocal
++aclocal_DATA = share/zthread.m4 share/pthread.m4
+
+-## install the config script & m4 macros
+-install-data-hook:
+- $(mkinstalldirs) $(datadir)/aclocal
+- $(INSTALL_DATA) $(top_srcdir)/share/zthread.m4 $(datadir)/aclocal
+- $(INSTALL_DATA) $(top_srcdir)/share/pthread.m4 $(datadir)/aclocal
+- mkdir -p $(DESTDIR)$(includedir)/zthread
+- cp -pR $(top_srcdir)/include/zthread $(DESTDIR)$(includedir)/
+-
+-## uninstall the config script & m4 macros
+-uninstall-local:
+- -rm -rf $(datadir)/aclocal/pthread.m4
+- -rm -rf $(datadir)/aclocal/zthread.m4
++zincludedir = $(includedir)/zthread
++zinclude_HEADERS = include/zthread/*.h
+
+ distclean-local:
+ -rm -rf $(top_srcdir)/$(PACKAGE)-$(VERSION).tar.gz
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -21,8 +21,6 @@
+ INCLUDES = -I$(top_srcdir)/include
+ SUBDIRS=.
+
+-libdir=$(prefix)/lib
+-
+ lib_LTLIBRARIES = libZThread.la
+
+ libZThread_la_LIBADD=@LINKER_OPTIONS@ @EXTRA_LINKER_OPTIONS@
diff --git a/dev-libs/zthread/files/zthread-2.3.2-clang.patch b/dev-libs/zthread/files/zthread-2.3.2-clang.patch
new file mode 100644
index 000000000000..13dd91ea2ca5
--- /dev/null
+++ b/dev-libs/zthread/files/zthread-2.3.2-clang.patch
@@ -0,0 +1,16 @@
+fix compile when using clang as $CC:
+
+Based on patch from https://bugs.launchpad.net/hugin/+bug/1213585 (rebased)
+
+diff -r 2a43e83684d5 src/foreign/zthread/include/zthread/Guard.h
+--- a/include/zthread/Guard.h Sat Aug 10 11:31:46 2013 +0200
++++ b/include/zthread/Guard.h Sun Aug 18 09:46:43 2013 +0200
+@@ -108,7 +108,7 @@
+ }
+
+ template <class LockType>
+- static void createScope(LockHolder<LockType>& l, unsigned long ms) {
++ static bool createScope(LockHolder<LockType>& l, unsigned long ms) {
+
+ if(Scope1::createScope(l, ms))
+ if(!Scope2::createScope(l, ms)) {
diff --git a/dev-libs/zthread/files/zthread-2.3.2-gcc47.patch b/dev-libs/zthread/files/zthread-2.3.2-gcc47.patch
new file mode 100644
index 000000000000..57b122d22c5f
--- /dev/null
+++ b/dev-libs/zthread/files/zthread-2.3.2-gcc47.patch
@@ -0,0 +1,25 @@
+Description: Make sure to use qualified lookups.
+http://bugs.debian.org/667430
+https://bugs.gentoo.org/show_bug.cgi?id=414133
+
+Author: Cyril Brulebois <kibi@debian.org>
+--- a/include/zthread/Guard.h
++++ b/include/zthread/Guard.h
+@@ -428,7 +428,7 @@
+ template <class U, class V>
+ Guard(Guard<U, V>& g) : LockHolder<LockType>(g) {
+
+- LockingPolicy::shareScope(*this, extract(g));
++ LockingPolicy::shareScope(*this, this->extract(g));
+
+ }
+
+@@ -458,7 +458,7 @@
+ template <class U, class V>
+ Guard(Guard<U, V>& g, LockType& lock) : LockHolder<LockType>(lock) {
+
+- LockingPolicy::transferScope(*this, extract(g));
++ LockingPolicy::transferScope(*this, this->extract(g));
+
+ }
+
diff --git a/dev-libs/zthread/files/zthread-2.3.2-m4-quote.patch b/dev-libs/zthread/files/zthread-2.3.2-m4-quote.patch
new file mode 100644
index 000000000000..72163a3b12a3
--- /dev/null
+++ b/dev-libs/zthread/files/zthread-2.3.2-m4-quote.patch
@@ -0,0 +1,26 @@
+fix m4 warnings:
+zthread.m4:34: warning: underquoted definition of AM_PATH_ZTHREAD
+pthread.m4:39: warning: underquoted definition of AM_DETECT_PTHREAD
+
+--- a/share/zthread.m4
++++ b/share/zthread.m4
+@@ -31,7 +31,7 @@
+ dnl ZTHREAD_CXXFLAGS
+ dnl ZTHREAD_LIBS
+ dnl
+-AC_DEFUN(AM_PATH_ZTHREAD,
++AC_DEFUN([AM_PATH_ZTHREAD],
+ [
+
+
+--- a/share/pthread.m4
++++ b/share/pthread.m4
+@@ -36,7 +36,7 @@
+ GNU Pth can also be used if it was configured with --enable-pthread.
+ EOF
+
+-AC_DEFUN(AM_DETECT_PTHREAD,
++AC_DEFUN([AM_DETECT_PTHREAD],
+ [
+
+ pthread_explicit="no"
diff --git a/dev-libs/zthread/files/zthread-2.3.2-no-fpermissive-r1.diff b/dev-libs/zthread/files/zthread-2.3.2-no-fpermissive-r1.diff
new file mode 100644
index 000000000000..94b42eedfbf3
--- /dev/null
+++ b/dev-libs/zthread/files/zthread-2.3.2-no-fpermissive-r1.diff
@@ -0,0 +1,94 @@
+--- a/include/zthread/Guard.h 2008-07-22 14:46:28.000000000 +0200
++++ b/include/zthread/Guard.h 2008-07-22 14:51:41.000000000 +0200
+@@ -491,7 +491,7 @@
+
+ try {
+
+- if(!isDisabled())
++ if(!LockHolder<LockType>::isDisabled())
+ LockingPolicy::destroyScope(*this);
+
+ } catch (...) { /* ignore */ }
+--- a/src/MutexImpl.h 2008-07-22 14:54:40.000000000 +0200
++++ b/src/MutexImpl.h 2008-07-22 15:03:30.000000000 +0200
+@@ -153,7 +153,7 @@
+
+ _owner = self;
+
+- ownerAcquired(self);
++ MutexImpl<List,Behavior>::ownerAcquired(self);
+
+ }
+
+@@ -164,7 +164,7 @@
+ _waiters.insert(self);
+ m.acquire();
+
+- waiterArrived(self);
++ MutexImpl<List, Behavior>::waiterArrived(self);
+
+ {
+
+@@ -173,7 +173,7 @@
+
+ }
+
+- waiterDeparted(self);
++ MutexImpl<List, Behavior>::waiterDeparted(self);
+
+ m.release();
+
+@@ -192,7 +192,7 @@
+ assert(_owner == 0);
+ _owner = self;
+
+- ownerAcquired(self);
++ MutexImpl<List, Behavior>::ownerAcquired(self);
+
+ break;
+
+@@ -236,7 +236,7 @@
+
+ _owner = self;
+
+- ownerAcquired(self);
++ MutexImpl<List, Behavior>::ownerAcquired(self);
+
+ }
+
+@@ -253,7 +253,7 @@
+
+ m.acquire();
+
+- waiterArrived(self);
++ MutexImpl<List, Behavior>:: waiterArrived(self);
+
+ {
+
+@@ -262,7 +262,7 @@
+
+ }
+
+- waiterDeparted(self);
++ MutexImpl<List, Behavior>::waiterDeparted(self);
+
+ m.release();
+
+@@ -284,7 +284,7 @@
+ assert(0 == _owner);
+ _owner = self;
+
+- ownerAcquired(self);
++ MutexImpl<List, Behavior>::ownerAcquired(self);
+
+ break;
+
+@@ -326,7 +326,7 @@
+
+ _owner = 0;
+
+- ownerReleased(impl);
++ MutexImpl<List, Behavior>::ownerReleased(impl);
+
+ // Try to find a waiter with a backoff & retry scheme
+ for(;;) {
diff --git a/dev-libs/zthread/files/zthread-2.3.2-no-fpermissive.diff b/dev-libs/zthread/files/zthread-2.3.2-no-fpermissive.diff
new file mode 100644
index 000000000000..21fad7c52c8e
--- /dev/null
+++ b/dev-libs/zthread/files/zthread-2.3.2-no-fpermissive.diff
@@ -0,0 +1,94 @@
+--- include/zthread/Guard.h.orig 2008-07-22 14:46:28.000000000 +0200
++++ include/zthread/Guard.h 2008-07-22 14:51:41.000000000 +0200
+@@ -491,7 +491,7 @@
+
+ try {
+
+- if(!isDisabled())
++ if(!LockHolder<LockType>::isDisabled())
+ LockingPolicy::destroyScope(*this);
+
+ } catch (...) { /* ignore */ }
+--- src/MutexImpl.h.orig 2008-07-22 14:54:40.000000000 +0200
++++ src/MutexImpl.h 2008-07-22 15:03:30.000000000 +0200
+@@ -153,7 +153,7 @@
+
+ _owner = self;
+
+- ownerAcquired(self);
++ MutexImpl<List,Behavior>::ownerAcquired(self);
+
+ }
+
+@@ -164,7 +164,7 @@
+ _waiters.insert(self);
+ m.acquire();
+
+- waiterArrived(self);
++ MutexImpl<List, Behavior>::waiterArrived(self);
+
+ {
+
+@@ -173,7 +173,7 @@
+
+ }
+
+- waiterDeparted(self);
++ MutexImpl<List, Behavior>::waiterDeparted(self);
+
+ m.release();
+
+@@ -192,7 +192,7 @@
+ assert(_owner == 0);
+ _owner = self;
+
+- ownerAcquired(self);
++ MutexImpl<List, Behavior>::ownerAcquired(self);
+
+ break;
+
+@@ -236,7 +236,7 @@
+
+ _owner = self;
+
+- ownerAcquired(self);
++ MutexImpl<List, Behavior>::ownerAcquired(self);
+
+ }
+
+@@ -253,7 +253,7 @@
+
+ m.acquire();
+
+- waiterArrived(self);
++ MutexImpl<List, Behavior>:: waiterArrived(self);
+
+ {
+
+@@ -262,7 +262,7 @@
+
+ }
+
+- waiterDeparted(self);
++ MutexImpl<List, Behavior>::waiterDeparted(self);
+
+ m.release();
+
+@@ -284,7 +284,7 @@
+ assert(0 == _owner);
+ _owner = self;
+
+- ownerAcquired(self);
++ MutexImpl<List, Behavior>::ownerAcquired(self);
+
+ break;
+
+@@ -326,7 +326,7 @@
+
+ _owner = 0;
+
+- ownerReleased(impl);
++ MutexImpl<List, Behavior>::ownerReleased(impl);
+
+ // Try to find a waiter with a backoff & retry scheme
+ for(;;) {