summaryrefslogtreecommitdiff
path: root/dev-libs/yyjson/yyjson-0.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-09 18:31:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-09 18:31:35 +0100
commitfb7c221776ce0bda5eb40ef32cb74daa98aed0d7 (patch)
tree0da74e27cfe965ce494b4be29eb9b4d04dda8259 /dev-libs/yyjson/yyjson-0.9.0.ebuild
parent7e8f29e487b79a183d66ca22f1e54dab5c47a409 (diff)
gentoo auto-resync : 09:04:2024 - 18:31:35
Diffstat (limited to 'dev-libs/yyjson/yyjson-0.9.0.ebuild')
-rw-r--r--dev-libs/yyjson/yyjson-0.9.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/yyjson/yyjson-0.9.0.ebuild b/dev-libs/yyjson/yyjson-0.9.0.ebuild
new file mode 100644
index 000000000000..d9b3e44def4d
--- /dev/null
+++ b/dev-libs/yyjson/yyjson-0.9.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Fast JSON library in C"
+HOMEPAGE="https://github.com/ibireme/yyjson https://ibireme.github.io/yyjson/doc/doxygen/html/"
+SRC_URI="https://github.com/ibireme/yyjson/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT test? ( BSD )"
+SLOT="0/0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="doc test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="doc? ( app-text/doxygen )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.0-disable-werror.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DYYJSON_BUILD_DOC=$(usex doc)
+ -DYYJSON_BUILD_TESTS=$(usex test)
+ -DYYJSON_ENABLE_VALGRIND=OFF
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ use doc && dodoc -r "${BUILD_DIR}"/doxygen/html
+}