summaryrefslogtreecommitdiff
path: root/dev-libs/wayland-protocols
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-10 07:26:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-10 07:26:51 +0100
commit34d9839f7e484ac761071da50298470aa5ef5123 (patch)
treea9968b72c6a227a35aef8fa59c04902ead833236 /dev-libs/wayland-protocols
parent4e6c4afbf915139e378349649c943e7df6b21efa (diff)
gentoo auto-resync : 10:07:2022 - 07:26:51
Diffstat (limited to 'dev-libs/wayland-protocols')
-rw-r--r--dev-libs/wayland-protocols/Manifest2
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.26.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/wayland-protocols/Manifest b/dev-libs/wayland-protocols/Manifest
index cbbebe2c83b7..77e615a60dcd 100644
--- a/dev-libs/wayland-protocols/Manifest
+++ b/dev-libs/wayland-protocols/Manifest
@@ -1,4 +1,6 @@
DIST wayland-protocols-1.25.tar.xz 79784 BLAKE2B 6ca7fdc910bfd70ee5c3bb192bcf1c79c66c4bb713531b2d1d493bd3ec8509e1231176144d75f4e97a4c6ccc4ee1d836a7ac1cfeaaa59e927f10fa4a40cf023a SHA512 8269694a0780e4d32f1982ff4cbb50b1ef85f08157b9486bc6d7e489c64665a9d9f959121d0eede7c7b108a604d974b64d74cfdef8b5f14304465309afb0768f
+DIST wayland-protocols-1.26.tar.xz 81028 BLAKE2B 0813b8117c48b965560c3f112f67fa209f29b0c40fab2b46f46ccae227d68902277cce06281a6bd938fb3c2186e0cf4ea3670ed6d3b48b51ed655012bb1452ce SHA512 fa9c3963b548197461c8c0b9e16ebbf9cfa5b60053fc17f51b41e63a55b8c5420dd7e42313f93946b438ab47f04e1cd17bc92aae9e1074b47177dc7ce7042167
EBUILD wayland-protocols-1.25.ebuild 755 BLAKE2B 3fc5c050521210e255e4f84757d8db55799f8f1f24a29cb80212e7961f73c16e043a64f76dfa3185aa56ed20a3e0759247f87cc41ff9f1adde61b147a276d2f4 SHA512 9ba008e0875dbcc8b3c597eb49073bce8afc3d94c0bf6837a684ef692e202b85eeb162640229199965922625763107080e4bf76388fc31b30d3eac2c758e08b6
+EBUILD wayland-protocols-1.26.ebuild 762 BLAKE2B 4f80b6c474c0ea97061ef6fb7703479bb82831a9a25450269356f967855e5b2d255d09a55db9a876ff7789dd8eab5d32c875c3947bf6e64c8eeabeb4c3faed4d SHA512 09dab59db34d5361d9630dc45c7728cf20c5f4491f6022093062b37756b776404964031664dd97efaaa878eb6fc850ce861b32d8e764173ecb28d432452ed719
EBUILD wayland-protocols-9999.ebuild 762 BLAKE2B 4f80b6c474c0ea97061ef6fb7703479bb82831a9a25450269356f967855e5b2d255d09a55db9a876ff7789dd8eab5d32c875c3947bf6e64c8eeabeb4c3faed4d SHA512 09dab59db34d5361d9630dc45c7728cf20c5f4491f6022093062b37756b776404964031664dd97efaaa878eb6fc850ce861b32d8e764173ecb28d432452ed719
MISC metadata.xml 231 BLAKE2B 6373a9c04316f777f87754fbb7cbc856493138d32bdb05d1015946ebbb359c4b8adb9372554097833d5c9a20e00e32fa0a1c90995d9299dd2215a2cadcccbb73 SHA512 bf6ad5078a6775cd61d257939d41ec53d006124475da2949c55b4b3ac138ec85a88b9068c5920b1e781fadda963939b8f120f8864d82e10cf50e09cc8052a6dc
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.26.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.26.ebuild
new file mode 100644
index 000000000000..fd84b9649f01
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.26.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/${PN}.git/"
+ inherit git-r3
+else
+ SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( dev-libs/wayland )
+"
+RDEPEND=""
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}