summaryrefslogtreecommitdiff
path: root/dev-libs/wayland-protocols/wayland-protocols-1.33.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-22 04:49:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-22 04:49:56 +0000
commit43d149cba3ac08d5111255f8cf374bbe7ec343c0 (patch)
treef70bfd2292f568f1fb9a6e2166280c8e64d89bb5 /dev-libs/wayland-protocols/wayland-protocols-1.33.ebuild
parentb6e823198d27bc8b1abf6ad0956f3b33ff1d35a0 (diff)
gentoo auto-resync : 22:01:2024 - 04:49:56
Diffstat (limited to 'dev-libs/wayland-protocols/wayland-protocols-1.33.ebuild')
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.33.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.33.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.33.ebuild
new file mode 100644
index 000000000000..7310be696158
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.33.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/${PN}.git/"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/releases/${PV}/downloads/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( dev-libs/wayland )
+"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}