summaryrefslogtreecommitdiff
path: root/dev-libs/wayland-protocols/wayland-protocols-1.32.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-06 16:14:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-06 16:14:21 +0100
commit5c92379e3a6732ff2855a56c60576983ae42e288 (patch)
treecfc3b84baaef518de09d10b5305a3f4abbc16dd7 /dev-libs/wayland-protocols/wayland-protocols-1.32.ebuild
parent8e3281f71945b4cccca5a44f2f467f3bff4ac45c (diff)
gentoo auto-resync : 06:07:2023 - 16:14:21
Diffstat (limited to 'dev-libs/wayland-protocols/wayland-protocols-1.32.ebuild')
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.32.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.32.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.32.ebuild
new file mode 100644
index 000000000000..761831b38427
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.32.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/${PN}.git/"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/releases/${PV}/downloads/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( dev-libs/wayland )
+"
+RDEPEND=""
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}