summaryrefslogtreecommitdiff
path: root/dev-libs/uulib/uulib-0.5.20-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-04 09:13:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-04 09:13:50 +0000
commit0bb8253b38dc8638a46b66ba909c1bfd1054e1ef (patch)
treed408176c81eb4f81d8b3e95a66abc8eedec620e4 /dev-libs/uulib/uulib-0.5.20-r3.ebuild
parent1f709ed82b8014b4c156f87c66cee7d0d1d3905d (diff)
gentoo auto-resync : 04:11:2022 - 09:13:50
Diffstat (limited to 'dev-libs/uulib/uulib-0.5.20-r3.ebuild')
-rw-r--r--dev-libs/uulib/uulib-0.5.20-r3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/uulib/uulib-0.5.20-r3.ebuild b/dev-libs/uulib/uulib-0.5.20-r3.ebuild
new file mode 100644
index 000000000000..d90186cd79ae
--- /dev/null
+++ b/dev-libs/uulib/uulib-0.5.20-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_P=uudeview-${PV}
+
+DESCRIPTION="Library that supports Base64 (MIME), uuencode, xxencode and binhex coding"
+HOMEPAGE="http://www.fpx.de/fp/Software/UUDeview/"
+SRC_URI="http://www.fpx.de/fp/Software/UUDeview/download/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}/${PN}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-libtool.patch # 780018
+ "${FILESDIR}"/${PN}-0.5.20-Fix-Wimplicit-function-declaration-for-strerror.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}