summaryrefslogtreecommitdiff
path: root/dev-libs/unittest++/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-libs/unittest++/files
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-libs/unittest++/files')
-rw-r--r--dev-libs/unittest++/files/unittest++-2.0.0-Add-support-for-LIB_SUFFIX.patch55
-rw-r--r--dev-libs/unittest++/files/unittest++-2.0.0-cmake-fix-pkgconfig-dir-path-on-FreeBSD.patch28
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-libs/unittest++/files/unittest++-2.0.0-Add-support-for-LIB_SUFFIX.patch b/dev-libs/unittest++/files/unittest++-2.0.0-Add-support-for-LIB_SUFFIX.patch
new file mode 100644
index 000000000000..fcaad5b0e69f
--- /dev/null
+++ b/dev-libs/unittest++/files/unittest++-2.0.0-Add-support-for-LIB_SUFFIX.patch
@@ -0,0 +1,55 @@
+From 0757ba8f903fc94ac852c8ba394cd96358b0e2c7 Mon Sep 17 00:00:00 2001
+From: Christoph Willing <chris.willing@iinet.net.au>
+Date: Mon, 23 Jan 2017 17:49:12 +1000
+Subject: [PATCH] Add support for LIB_SUFFIX
+
+Signed-off-by: Christoph Willing <chris.willing@iinet.net.au>
+---
+ CMakeLists.txt | 10 ++++++----
+ 1 file changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index a0f5511..6b490ef 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -11,6 +11,8 @@ option(UTPP_AMPLIFY_WARNINGS
+ "Set this to OFF if you wish to use CMake default warning levels; should generally only use to work around support issues for your specific compiler"
+ ON)
+
++set(LIB_SUFFIX "" CACHE STRING "Identifier to add to end of lib directory name e.g. 64 for lib64")
++
+ if(MSVC14 OR MSVC12)
+ # has the support we need
+ else()
+@@ -92,10 +94,10 @@ else()
+ set (UTPP_INSTALL_DESTINATION "include/UnitTestPP")
+ endif()
+
+-set(config_install_dir_ lib/cmake/${PROJECT_NAME})
++set(config_install_dir_ lib${LIB_SUFFIX}/cmake/${PROJECT_NAME})
+ set(targets_export_name_ "${PROJECT_NAME}Targets")
+
+-install(TARGETS UnitTest++ EXPORT "${targets_export_name_}" DESTINATION lib)
++install(TARGETS UnitTest++ EXPORT "${targets_export_name_}" DESTINATION lib${LIB_SUFFIX})
+ install(FILES ${headers_} DESTINATION ${UTPP_INSTALL_DESTINATION})
+ install(FILES ${platformHeaders_} DESTINATION ${UTPP_INSTALL_DESTINATION}/${platformDir_})
+ install(FILES cmake/UnitTest++Config.cmake DESTINATION "${config_install_dir_}")
+@@ -103,13 +105,13 @@ install(EXPORT "${targets_export_name_}" DESTINATION "${config_install_dir_}")
+
+ set(prefix ${CMAKE_INSTALL_PREFIX})
+ set(exec_prefix ${CMAKE_INSTALL_PREFIX}/bin)
+-set(libdir ${CMAKE_INSTALL_PREFIX}/lib)
++set(libdir ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+ set(includedir ${CMAKE_INSTALL_PREFIX}/include/UnitTest++)
+ configure_file("UnitTest++.pc.in" "UnitTest++.pc" @ONLY)
+ if(${CMAKE_SYSTEM_NAME} STREQUAL "FreeBSD")
+ set(pkgconfdir ${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig)
+ else()
+- set(pkgconfdir ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
++ set(pkgconfdir ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}/pkgconfig)
+ endif()
+ install(FILES "${CMAKE_CURRENT_BINARY_DIR}/UnitTest++.pc"
+ DESTINATION "${pkgconfdir}")
+--
+2.26.2
+
diff --git a/dev-libs/unittest++/files/unittest++-2.0.0-cmake-fix-pkgconfig-dir-path-on-FreeBSD.patch b/dev-libs/unittest++/files/unittest++-2.0.0-cmake-fix-pkgconfig-dir-path-on-FreeBSD.patch
new file mode 100644
index 000000000000..44c243670027
--- /dev/null
+++ b/dev-libs/unittest++/files/unittest++-2.0.0-cmake-fix-pkgconfig-dir-path-on-FreeBSD.patch
@@ -0,0 +1,28 @@
+From 85bade33f596a4dab33eb6d44f662d64fc20f510 Mon Sep 17 00:00:00 2001
+From: Iblis Lin <iblis@hs.ntnu.edu.tw>
+Date: Sat, 14 Jan 2017 23:00:24 +0800
+Subject: [PATCH] cmake: fix pkgconfig dir path on FreeBSD
+
+---
+ CMakeLists.txt | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index fb10f47..a0f5511 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -106,5 +106,10 @@ set(exec_prefix ${CMAKE_INSTALL_PREFIX}/bin)
+ set(libdir ${CMAKE_INSTALL_PREFIX}/lib)
+ set(includedir ${CMAKE_INSTALL_PREFIX}/include/UnitTest++)
+ configure_file("UnitTest++.pc.in" "UnitTest++.pc" @ONLY)
++if(${CMAKE_SYSTEM_NAME} STREQUAL "FreeBSD")
++ set(pkgconfdir ${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig)
++else()
++ set(pkgconfdir ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
++endif()
+ install(FILES "${CMAKE_CURRENT_BINARY_DIR}/UnitTest++.pc"
+- DESTINATION "${CMAKE_INSTALL_PREFIX}/lib/pkgconfig")
++ DESTINATION "${pkgconfdir}")
+--
+2.26.2
+