summaryrefslogtreecommitdiff
path: root/dev-libs/ucl/ucl-1.03-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/ucl/ucl-1.03-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/ucl/ucl-1.03-r1.ebuild')
-rw-r--r--dev-libs/ucl/ucl-1.03-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/ucl/ucl-1.03-r1.ebuild b/dev-libs/ucl/ucl-1.03-r1.ebuild
new file mode 100644
index 000000000000..38a7acb307b6
--- /dev/null
+++ b/dev-libs/ucl/ucl-1.03-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="the UCL Compression Library"
+HOMEPAGE="http://www.oberhumer.com/opensource/ucl/"
+SRC_URI="http://www.oberhumer.com/opensource/ucl/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="static-libs"
+
+DEPEND="!!dev-libs/libucl"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-CFLAGS.patch
+ epatch "${FILESDIR}"/${P}-x32.patch #426334
+
+ # lzo (and ucl) have some weird sort of mfx_* set of autoconf macros
+ # which may only be distributed with lzo itself? Rescue them and
+ # place them into acinclude.m4 because there doesn't seem to be an
+ # m4/...
+ sed -n -e '/^AC_DEFUN.*mfx_/,/^])#$/p' aclocal.m4 > acinclude.m4 || die "Unable to rescue mfx_* autoconf macros."
+
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # bug #585632
+ append-cflags -std=c90
+
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}