summaryrefslogtreecommitdiff
path: root/dev-libs/tut/tut-2016.12.19.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/tut/tut-2016.12.19.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/tut/tut-2016.12.19.ebuild')
-rw-r--r--dev-libs/tut/tut-2016.12.19.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-libs/tut/tut-2016.12.19.ebuild b/dev-libs/tut/tut-2016.12.19.ebuild
new file mode 100644
index 000000000000..2d40e8998857
--- /dev/null
+++ b/dev-libs/tut/tut-2016.12.19.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='threads(+)'
+NO_WAF_LIBDIR=yes
+
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="C++ Template Unit Test Framework"
+HOMEPAGE="http://mrzechonek.github.io/tut-framework/"
+SRC_URI="https://github.com/mrzechonek/tut-framework/archive/${PV//./-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=${PYTHON_DEPS}
+RDEPEND=""
+
+S="${WORKDIR}/tut-framework-${PV//./-}"