summaryrefslogtreecommitdiff
path: root/dev-libs/trio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /dev-libs/trio
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'dev-libs/trio')
-rw-r--r--dev-libs/trio/Manifest3
-rw-r--r--dev-libs/trio/metadata.xml11
-rw-r--r--dev-libs/trio/trio-1.16.ebuild38
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/trio/Manifest b/dev-libs/trio/Manifest
new file mode 100644
index 000000000000..243c6f909b97
--- /dev/null
+++ b/dev-libs/trio/Manifest
@@ -0,0 +1,3 @@
+DIST trio-1.16.tar.gz 167337 BLAKE2B 0f284e0a130723f7511c0e874276c79c1addc1329833d14f0b76bae9808d90b76a2b26817ee85da71c3997360918cb534917a11bbe35ba627d1012cd8a2f6299 SHA512 3a8bac3ed001f70f498bd2ab0881ed6d3760bc978bf9ff587c3fc1d5d7a38205f779c5fe445f41edaa9e23c15bc1b4a521916e19161277741bc8e2f744b46c69
+EBUILD trio-1.16.ebuild 812 BLAKE2B b0058b7e1079f6619f3aaec03fd13bc80f9dd99139d4959359caecc12b9ab312260b906863a63805ede02873e94e38714d898ba4664afebe96f479fcb6c1eae3 SHA512 92799664ce644cb5a0b63c7bc493d3dcc82eacce4328492e0012a82aba88a106e8ca4ba59f562cd106dd9f75fee95fb74b4eb18cee7f6214f3ab41d0bdc32f87
+MISC metadata.xml 328 BLAKE2B c7b164aa25ad9fab55823ed0ff243062f73a4a7ae3d6d9630f72f9d912406a82f30fd9629cfe3441552478cd32b0ff4247b9fc7fe7eefe0fb65ae52cda4de5f2 SHA512 e507df5cc9d38e4f11eee8a2dc26390fb0380c596c91c1bb4b3f3a4d60303e0707af3679fecf0d1a0c560998e66284cb8cd24a539f7d47b37f046d01d5be4209
diff --git a/dev-libs/trio/metadata.xml b/dev-libs/trio/metadata.xml
new file mode 100644
index 000000000000..c71b42fc85c6
--- /dev/null
+++ b/dev-libs/trio/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">ctrio</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/trio/trio-1.16.ebuild b/dev-libs/trio/trio-1.16.ebuild
new file mode 100644
index 000000000000..1980624be416
--- /dev/null
+++ b/dev-libs/trio/trio-1.16.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Portable string functions, focus on the *printf() and *scanf() clones"
+HOMEPAGE="https://daniel.haxx.se/projects/trio/"
+SRC_URI="mirror://sourceforge/ctrio/${P}.tar.gz"
+
+LICENSE="trio"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+HTML_DOCS=( html/. )
+
+src_prepare() {
+ default
+ sed -i '/$(CC)/s/-o/$(LOCAL_LDFLAGS) -o/' Makefile.in || die
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" LOCAL_LDFLAGS="${LDFLAGS}"
+ ln -s libtrio.so.2{.0.0,} || die
+ ln -s libtrio.so{.2.0.0,} || die
+}
+
+src_test() {
+ emake LOCAL_LDFLAGS="${LDFLAGS}" regression
+ LD_LIBRARY_PATH=".:${LD_LIBRARY_PATH}" ./regression || die
+}
+
+src_install() {
+ doheader trio*.h
+ dolib.so libtrio.so*
+ einstalldocs
+}