summaryrefslogtreecommitdiff
path: root/dev-libs/tntnet/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/tntnet/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/tntnet/files')
-rw-r--r--dev-libs/tntnet/files/tntnet-2.0-zlib-minizip.patch65
-rw-r--r--dev-libs/tntnet/files/tntnet.initd29
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-libs/tntnet/files/tntnet-2.0-zlib-minizip.patch b/dev-libs/tntnet/files/tntnet-2.0-zlib-minizip.patch
new file mode 100644
index 000000000000..07b4836319d4
--- /dev/null
+++ b/dev-libs/tntnet/files/tntnet-2.0-zlib-minizip.patch
@@ -0,0 +1,65 @@
+--- a/configure.in
++++ b/configure.in
+@@ -18,6 +18,7 @@
+
+ AC_PROG_CXX
+ AC_PROG_LIBTOOL
++PKG_PROG_PKG_CONFIG
+
+ AC_LANG(C++)
+ ACX_PTHREAD
+@@ -25,6 +26,12 @@
+ AC_CHECK_HEADER([zlib.h], , AC_MSG_ERROR([zlib not found]))
+ AC_CHECK_HEADER([cxxtools/net/tcpsocket.h], , AC_MSG_ERROR([cxxtools headers not found]))
+
++PKG_CHECK_MODULES([MINIZIP], [minizip],
++ [HAVE_MINIZIP=true], [HAVE_MINIZIP=false])
++AC_SUBST([MINIZIP_CFLAGS])
++AC_SUBST([MINIZIP_LIBS])
++AM_CONDITIONAL([HAVE_MINIZIP], [test $HAVE_MINIZIP = true])
++
+ AC_ARG_WITH([epoll],
+ AS_HELP_STRING([--with-epoll=yes|no|probe], [use epoll]),
+ [epoll_option=$withval],
+--- a/framework/common/Makefile.am
++++ b/framework/common/Makefile.am
+@@ -23,7 +23,6 @@ libtntnet_la_SOURCES = \
+ httpparser.cpp \
+ httprequest.cpp \
+ httpreply.cpp \
+- ioapi.c \
+ job.cpp \
+ langlib.cpp \
+ listener.cpp \
+@@ -41,16 +40,13 @@ libtntnet_la_SOURCES = \
+ stringlessignorecase.cpp \
+ tntconfig.cpp \
+ tntnet.cpp \
+- unzip.c \
+ unzipfile.cpp \
+ urlescostream.cpp \
+ urlmapper.cpp \
+ util.cpp \
+ worker.cpp \
+ zdata.cpp \
+- crypt.h \
+- ioapi.h \
+- unzip.h
++ crypt.h
+
+ nobase_include_HEADERS = \
+ tnt/applicationunlocker.h \
+@@ -145,3 +141,13 @@ noinst_HEADERS += \
+ tnt/stressjob.h
+ endif
+
++if HAVE_MINIZIP
++libtntnet_la_CXXFLAGS += $(MINIZIP_CFLAGS)
++libtntnet_la_LDFLAGS += $(MINIZIP_LIBS)
++else
++libtntnet_la_SOURCES += \
++ ioapi.c \
++ ioapi.h \
++ unzip.c \
++ unzip.h
++endif
diff --git a/dev-libs/tntnet/files/tntnet.initd b/dev-libs/tntnet/files/tntnet.initd
new file mode 100644
index 000000000000..54982bddd6e6
--- /dev/null
+++ b/dev-libs/tntnet/files/tntnet.initd
@@ -0,0 +1,29 @@
+#!/sbin/openrc-run
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+PIDFILE="/var/run/tntnet.pid"
+
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting tntnet"
+ start-stop-daemon --start --quiet --pidfile $PIDFILE --exec /usr/bin/tntnet
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping tntnet"
+ start-stop-daemon --stop --pidfile $PIDFILE --exec /usr/bin/tntnet
+ eend $?
+}
+
+reload() {
+ # FIXME: Remove --stop and --oknodo as soon as baselayout-1 has been removed...
+ # finally...
+ ebegin "Reloading tntnet configuration"
+ start-stop-daemon --stop --oknodo --pidfile $PIDFILE --signal HUP --exec /usr/bin/tntnet
+ eend $?
+}