summaryrefslogtreecommitdiff
path: root/dev-libs/tinyxml2/tinyxml2-5.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/tinyxml2/tinyxml2-5.0.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/tinyxml2/tinyxml2-5.0.1.ebuild')
-rw-r--r--dev-libs/tinyxml2/tinyxml2-5.0.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/tinyxml2/tinyxml2-5.0.1.ebuild b/dev-libs/tinyxml2/tinyxml2-5.0.1.ebuild
new file mode 100644
index 000000000000..2f447a61c6c0
--- /dev/null
+++ b/dev-libs/tinyxml2/tinyxml2-5.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib
+
+DESCRIPTION="A simple, small, efficient, C++ XML parser"
+HOMEPAGE="http://www.grinninglizard.com/tinyxml2/ https://github.com/leethomason/tinyxml2/"
+SRC_URI="https://github.com/leethomason/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0/5"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="static-libs test"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC_LIBS=$(usex static-libs)
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake-utils_src_configure
+}