summaryrefslogtreecommitdiff
path: root/dev-libs/tinyxml/tinyxml-2.6.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-libs/tinyxml/tinyxml-2.6.2-r2.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/tinyxml/tinyxml-2.6.2-r2.ebuild')
-rw-r--r--dev-libs/tinyxml/tinyxml-2.6.2-r2.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-libs/tinyxml/tinyxml-2.6.2-r2.ebuild b/dev-libs/tinyxml/tinyxml-2.6.2-r2.ebuild
deleted file mode 100644
index 52ba8c0050dd..000000000000
--- a/dev-libs/tinyxml/tinyxml-2.6.2-r2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-inherit flag-o-matic toolchain-funcs eutils multilib versionator
-
-DESCRIPTION="Simple and small C++ XML parser"
-HOMEPAGE="http://www.grinninglizard.com/tinyxml/index.html"
-SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV//./_}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-fbsd ~x64-macos ~x86-macos"
-IUSE="debug doc static-libs +stl"
-
-RDEPEND=""
-DEPEND="doc? ( app-doc/doxygen )"
-
-S="${WORKDIR}/${PN}"
-
-src_prepare() {
- local major_v=$(get_major_version)
- local minor_v=$(get_version_component_range 2-3)
-
- sed -e "s:@MAJOR_V@:$major_v:" \
- -e "s:@MINOR_V@:$minor_v:" \
- "${FILESDIR}"/Makefile-3 > Makefile || die
-
- epatch "${FILESDIR}"/${PN}-2.6.1-entity.patch
-
- use debug && append-cppflags -DDEBUG
- use stl && epatch "${FILESDIR}"/${P}-defineSTL.patch
-
- if ! use static-libs; then
- sed -e "/^all:/s/\$(name).a //" -i Makefile || die
- fi
-
- tc-export AR CXX RANLIB
-
- [[ ${CHOST} == *-darwin* ]] && export LIBDIR="${EPREFIX}"/usr/$(get_libdir)
-}
-
-src_install() {
- dolib.so *$(get_libname)*
-
- insinto /usr/include
- doins *.h
-
- dodoc {changes,readme}.txt
-
- use doc && dohtml -r docs/*
-}